NomanA on Thu, 15 Sep 2011 18:06:05

Everything was working fine on my Win8 preview installation until suddenly all immersive applications stopped coming up. Any time I click on one of these apps on start screen, the store app opens instead. I tried moving the tiles, pin/unpin store app, killing it from task manager, restarting PC, but for that specific account (it's a Local one) immersive apps don't work.

The only exception is Control Panel application which still opens. And of course Desktop is still reachable. The tiles do get updated with the latest status (news feed, temperature etc)

Other accounts on the PC (local or Live) work fine.

Is there some settings or file I can delete/modify to save this account, before I go and delete the account altogether?

Thanks in advance.


IslandDreamerTV on Thu, 15 Sep 2011 19:01:00

I am experiencing the same behavior. Metro apps refuse to work on the original user account (although they worked at first), but run fine on subsequent user accounts I have created.

NomanA on Thu, 15 Sep 2011 19:28:44

Do you also see store app opening when you click any metro app?

And like I said, immersive version of Control Panel works fine.

IslandDreamerTV on Thu, 15 Sep 2011 19:33:47

Yes, that's exactly what I see. I created three other user accounts (all tied to Windows Live IDs) and they work fine. It's only this original user account that has the issue.

Arik Cohen - msft on Fri, 16 Sep 2011 15:03:32

The following should fix the behavior.  Go to Control Panel, General and select "Refresh your PC without affecting your files".

We've seen a few issues where the licenses for a particular user don't get installed correctly -- this should fix that.


Thanks for the feedback on the Windows Developer Preview.

NomanA on Mon, 19 Sep 2011 20:40:41

Yes, doing this fixed the issue and it hasn't happened again yet. Deleting the account and re-creating it was probably easier, but I wanted to try this "Refresh" option (which worked fine). Thank you.

Arik Cohen - msft on Tue, 20 Sep 2011 07:38:02

Great -- glad it worked for you.


If someone else runs into this -- please post here BEFORE doing the fix.  We'd love to run some diagnostics to get to the root cause of the issue.


Much appreciated,

Arik Cohen

Program Manager

Windows Store

darth21 on Thu, 29 Sep 2011 22:26:52

I have the same exact problem.

I had three user accounts, i linked one to a LiveID profile, and then deleted the account in the control panel. I think that's when tiles started working weird.


I'll try to refresh my PC later, hope it will work.

Lorendin on Sat, 01 Oct 2011 06:37:23

Hello Arik,

I got the same situation here. I did not do the fix yet, so if you need any further information or even remote access to my machine, let me know.




Just to add what I initially wrote in another thread:

1. After installing Windows 8 Developer Preview I created a local account.

2. I started metro apps and everything seems to work quite well. Now I added a new user with a live id (not connected with the local account).

3. I continued working with the new user that is identified by the live id. Everything was still ok.

4. I logged off and back in with my local account. I wanted to connect the local user with the live id. This failed with some hex code and I saw that it tried to create the live id user locally. Ok I already had that live id user.

5. I decided to delete the live id user and after that connect my live id user with the local account. This worked ok. Windows told me to use the live id the next time I log in. So I immediately logged off to continue using my live id.

When I now try to start any metro app now, the store app always opens. Going to the metro menu and clicking on the same app again shows the splash screen for some time and then the screen turns cyan. One click on the screen and the metro menu appears again. This happens for any metro app. Logging of or rebooting does not help. After that I turned off syncing but the problem still persists.

Any ideas how to fix this?

Edit: Just to add further information. I started Visual Studio and created a new JavaScript Metro Style App. I can run and test that app. The new app is added to the metro start menu and I can also start it from there. Existing metro apps like build, socialite, ... still cannot be started.

maartenvc on Sat, 08 Oct 2011 13:03:02

same problem here with windows 8 x86:

clean install from win7 pxe boot environment on asus eee pc

with net use map to drive w:


problem exists on live account and local account


method to fix not working as it can't find installation media (why can't I browse to w: from that message? )

(yes w: is again mapped before trying to run the mentioned option)


It's a resolution issue see

Suggestion: Please make a warning dialog when clicking on the buttons when the resolution is too low. Now it doesn't anything!

Kacey Green on Tue, 11 Oct 2011 07:07:03

My Iconia W500 is now doing this, I had a problem with the keyboard switcher so I ran a refresh and now the metro apps don't work for my live ID, I haven't tried additional users for this issue.

Kacey Green on Mon, 17 Oct 2011 11:39:03

Local accounts I create work as expected. I deleted and re-added my live account and it worked at first and the next time the tablet was powered up the apps were launching the store again.

The live tiles for the apps I tested to check that the system wasn't opening the store are working but clicking them is again launching the store.


This behavior started after a refresh operation.

Steven - Support Engineer on Wed, 19 Oct 2011 22:01:15

Hey everyone,


Thank you for posting your feedback, we want to make sure we get the right info including your log files. Can you also submit feedback using the Windows Feedback Tool from the Connect Site associated with your Windows Developer Preview program? If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview. There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here.

Steven - Support Engineer on Wed, 09 Nov 2011 23:25:37

Hey MohammadKaa00x,


Have you tried pressing Windows key + Q in the second user account's Start screen to see if the application can be found there. If you find it, right click the tile to be able to pin the tile to your Start menu.


The only workarounds that I am aware of are to solve this problem is to refresh your PC or to use a different user profile.


You may want to check to see if you will be able to transfer the applications that you have purchased for when Windows Developer Preview is no longer usable. The evaluation copy of Windows Developer Preview expires on 3/11/2012.


Also, please see the quoted information below from the site that Windows Developer Preview can be downloaded from:
"The Windows 8 Developer Preview is a pre-beta version of Windows 8 for developers. These downloads include prerelease software that may change without notice. The software is provided as is, and you bear the risk of using it. It may not be stable, operate correctly or work the way the final version of the software will. It should not be used in a production environment. The features and functionality in the prerelease software may not appear in the final version. Some product features and functionality may require advanced or additional hardware, or installation of other software."

ryanswj on Wed, 30 Nov 2011 16:51:18

hello there! sorry to revive such an old thread, but I have this problem.

I have not done the refresh yet. Do you need any logs?


Steven - Support Engineer on Thu, 01 Dec 2011 03:19:45

Hey Ryanswj,


Logs will be provided with your submission if you use the Windows Feedback Tool to submit feedback regarding this problem. If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview. There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here.

ryanswj on Thu, 01 Dec 2011 03:33:45

Hi Steven! Glad to receive your reply. I am a MSDN subscriber (but I downloaded the preview from the windows dev centre

I am unable to find any link to the Microsoft Connect site and the Windows Feedback Tool.

Could you guide me to a page where these are available? Thanks!

Okay - I've found it. No need to reply. Thanks!

Steven - Support Engineer on Sat, 03 Dec 2011 22:14:12

Hey Ryanswj,


Thanks for the update and your feedback!

KariPaa on Mon, 27 Feb 2012 01:17:25

Exactly the same issue, see video here: About the suggested fix, does refreshing PC keep installed apps?

Another small but annoying issue: Metro Weather gadget temperature set to Celsius, reverts to Fahrenheit after reboot and shows Anaheim CA as my location. I have to open weather (which is now not possible, see above!) and close it to show my location in Celsius.


Steven - Support Engineer on Tue, 28 Feb 2012 02:50:19

Hey Kari,

Here is what will happen when you refresh your PC:

  • Your files and personalization settings won't change.
  • Your PC settings will be restored to their defaults.
  • Apps from Windows Store will be kept. All other apps will be removed.

Edit: The third point above means that you'll need to reinstall any applications that you have installed on Windows Developer Preview. However the Metro style applications that were included with Windows Developer Preview will remain after the refresh has completed.

An alternative solution would be to create a new user profile to see if the new user profile encounters the same problem. You can create a new user profile by:

  • Enter the Start screen
  • Click Control Panel
  • Click Users in the left column
  • Click Add a user in the right column

If the new user profile works properly, you could transfer your files from the old user account to the new user account and use it instead of your original user profile.

Hope that helps.


Exotic Hadron on Tue, 28 Feb 2012 14:19:45

I started experiencing this same problem with Socialite a while after I changed the owner of the C:\Program Files\Applications folder and its subfolders... Now starting Socialite leads to starting Windows Store.

Looks like Socialite's contract has been corrupted and the OS can't properly enumerate it, could it be so?