Creation of private link fails

Category: azure database for postgresql


vap78 on Tue, 14 Apr 2020 12:49:16


I'm trying to create a private link to a managed Postgre SQL database in Azure and it fails every time during deployment with such an error:

    "error": {
        "message""The resource operation completed with terminal provisioning state 'Failed'.",
        "details": [
                "message""The requested resource of type 'Microsoft.DBforPostgreSQL/servers/privateEndpointConnectionProxies' with name 'fsp-test.eaa28c53-a4dc-4f09-9da3-b0a9b59421b8' was not found.",
                "details": []

The private end point itself is created in the corresponding virtual network, but it remains in "Provisioning State" failed and there is no Private DNS Zone created.

When checking the event logs of the database blade , there is really an request to create such a resource and in some cases there is a log that it was successfully created while in other there is only an "Accepted" log entry. In both cases the resource is not there when searching for it via the Resource explorer.

Any idea what might be causing this issue?

Best regards



vap78 on Tue, 14 Apr 2020 14:02:11

Additionally I attempted this via a Power Shell command and it failed with the same error. 

Here the command:

az network private-endpoint create 
--name fsp-test 
--resource-group <vnet resource group>
--vnet-name <vnet>
--subnet <subnet>
--private-connection-resource-id <Postgre SQL instance ID> 
--group-ids postgresqlServer  
--connection-name fsp-test-conn

I got the same error:

Deployment failed. Correlation ID: <ID>. The requested resource of type 'Microsoft.DBforPostgreSQL/servers/privateEndpointConnectionProxies' with name 'fsp-test.4aa0b365-9ac6-4170-88a8-d9c955bf4ff1' was not found.

NavtejSaini-MSFT on Tue, 14 Apr 2020 23:28:58

Hi Vap78

Currently this is a known issue which stems from the use of same name of server that you have previously used in this subscription and deleted. Team is currently working on fixing this.

One way to mitigate it is to create a server with name that you have not used before and then create the Private Link it should work.

If any one doesn't want to do this and want to continue with the server they have, they may send a mail to AzConnect email with reference/link to this post, reference to my name(navtej), postgresql/mysql/mariadb server name(yes this happening for Maria and mysql db as well)  and region name and subscription id and we will try to mitigate it from back end.

Please revert if you have any other question.

Navtej S

NavtejSaini-MSFT on Sun, 19 Apr 2020 18:03:00

Hi Vasil

As conveyed through email your issue is now resolved. We have proposed the reply as an answer, please mark it as answer is we were able to help you.

Navtej S