Azure Database for PostgreSQL VNET service endpoints not working

Category: azure database for postgresql


Wouter Willaert on Thu, 07 Jun 2018 08:31:26


I'm having trouble getting Azure PostgreSQL to working with the `Microsoft.SQL` VNET service endpoint.

I've created a Azure PostgreSQL v10 server (GP_Gen5_2 sku), added the `Microsoft.SQL` to my vnet and added the appropiate vnet rule to my Azure PostgreSQL instance.
When trying to connect using `psql` from my Ubuntu VM I'm getting the following error:

psql "sslmode=require host=<host> port=5432 dbname=postgres" --username=<username>
psql: FATAL:  unrecognized configuration parameter "connection_Vnet"

I've tried recreating the PostgreSQL server, vnet rule and the `Microsoft.SQL` vnet service endpoint, but nothing works.
Tried both the Azure Portal and the Azure CLI.

Kind regards,

Wouter Willaert


Mike Ubezzi (Azure) on Thu, 07 Jun 2018 16:25:20

Hi Wouter,

Did you follow a specific set of instructions? I am going to provide you with the instructions on how to set this up. I am providing instructions for configuring this functionality via Azure Portal as well as the Azure CLI. 

Azure Portal

Create and manage Azure Database for PostgreSQL VNet service endpoints and VNet rules by using the Azure portal

Azure CLI

Create and manage Azure Database for PostgreSQL VNet service endpoints using Azure CLI

Please communicate any issues you encounter or if you are successful deploying this specific configuration. Regards, MIke

Mark Bolz [MSFT] on Fri, 08 Jun 2018 00:43:02

Greetings Wouter,

This is a known issue with VNet service endpoints, unfortunately, and I apologize. All other methods of connecting to PostgreSQL are unaffected. Our engineering team is working on a solution to address this problem globally. You can create a support case to receive direct assistance with this issue as well as updates for the fix.