Extensibility Tookit install does not show LS templates

Category: visual studio lsextensibility


PeterTrefren on Tue, 26 Feb 2013 18:00:22

Installed the LightSwitch Extensibility Toolkit 2011 and when I try to create a LS project I'm not able to see it as selectable a project type.  I've checked help and the toolkit is listed as installed.


Xpert360 on Wed, 27 Feb 2013 12:50:39

Did you install the VS2010 SDK for SP1? I'm assuming you are using LightSwitch 2011 here.

PeterTrefren on Wed, 27 Feb 2013 14:20:45

Yes I have installed the SDK.  I'm also running VS2012 and I am able to create LightSwitch apps with it but I don't see the template in my VS2010 environment. 

Xpert360 on Wed, 27 Feb 2013 15:20:05

Can you confirm that you have installed this one:


... and not


as from what I recall LightSwitch 2011 Extensibility Toolkit does need the SDK SP1 or the extensibilty templates do not show up.

PeterTrefren on Thu, 28 Feb 2013 00:35:09

I've verified I installed VS2010 SP1 SDK by using Programs and Features.

Justin Anderson on Thu, 28 Feb 2013 10:25:33

From an elevated developer command prompt, try "devenv /setup". This should reregister the extension (the extensibility toolkit), among other things, and the templates should appear in the new project dialog.

PeterTrefren on Thu, 28 Feb 2013 13:59:37

How do I run an elevated prompt?  I'm running the command prompt from VS 2010 and I'm getting an access error.

PeterTrefren on Thu, 28 Feb 2013 23:33:11

I ran both devenv /setup and devenv /installVSTemplates and both ran successfully but did not make the LightSwitch project type display.