Cemoo on Tue, 02 Feb 2016 11:12:30


I am a developer working on Visual Studio 2013 and I have a problem about graphic card that VS2013 using.

The problem is when i developing in windows form, resolution is different with Intel HD Graphics. Beacuse VS2013 is only using Intel HD Graphics. So when i run the project resultion is not good and i cannot understand the sizes of controls.

So i want to make VS2013 use my GTX graphic card. Is it possible? Or if i disable the Intel HD Driver, can my os use only GTX one?

By the way my os is win 10.



IanHuff - MSFT on Tue, 02 Feb 2016 17:48:53

Hey Cemoo,

I'm a bit confused as to the wording of the issue that you are reporting.
Could you perhaps share a screen shot of the resolution issues that you are seeing? In general what GFX card you are using the up to the OS, not to Visual Studio so I'm not sure if I can help here or not.

Greazer on Tue, 02 Feb 2016 20:41:19

Hi Cemoo,

I *may* understand what you're asking and have a couple of suggestions. First, you can disable Visual Studio from using hardware graphics acceleration at all. Depending on your scenario, this may not be a problem performance-wise at all, but will give you consistent behavior. To do this, open Tools->Options, then look Environment->General. Uncheck "Automatically adjust visual experience based on client performance". Then be sure that "Use hardware graphics acceleration if available" is unchecked.

If you DO find that your use of VS is not performing adequately after making this change, the only other thing I can tell you is that systems that ship with hybrid GPU solutions (as you are implying) typically have a control panel setting to choose the specific GPU a specific process should use. In this case, you'll be configuring "devenv.exe". Since you have an NVidia card, I believe this setting should be in the NVidia adapter control panel.

Hope this helps.