Not able to bind SSL certificate to my app service

Category: azure app service api apps public preview


ErinTech on Fri, 07 Dec 2018 16:38:47

I am trying to bind ssl certificate to my app service But I  did not find upload feature there. I also tried to upgrade my instance but still the same issue. Please have a look at below image

I am getting below in private certificate section :

Private Certificate
Private certificates (.pfx) can be used for SSL bindings and can be loaded to the certificate store for your app to consume. To understand how to load the certificates for your app to consume click on the learn more link. Uploaded certificates are not available for manual download from the Azure Management Portal, they can only be used by your app hosted on App Service after the required App Settings are set properly or used for SSL. Learn more

Aslo tried after upgrading the instance but same issue


AjayKumar-MSFT on Mon, 10 Dec 2018 09:31:31

We do not see an ‘image’ that you mentioned was attached here, for better clarity on this issue, could you please re-post the screenshot again? Ensure that you conceal any private information on the screenshot.

Yes, to bind a custom SSL certificate (a third-party certificate or App Service certificate) to your web app, your App Service plan must be in the BasicStandardPremium, or Isolated tier.

If you haven’t done already so, you may Sign-out and re-login to the Azure portal and then check, refer the document section Bind your SSL certificate for a detailed steps on the process.

If you are experiencing any issues posting images here, refer the blog How to Verify Your MSDN/TechNet Forums Account So that You Can Post Images and Links for more details on this topic.