OpenID error when using Google IdP

Category: azure security


Pedro Felix on Wed, 04 Apr 2012 16:51:35


I've a scenario where I'm using Google IdP.

Everything goes well on the protocol flow from my app to Google IdP, via ACS. However, when the Google IdP redirects to ACS I immediatly receive the following:

ACS30000: There was an error processing an OpenID sign-in response.

I've tried two different tenants, located on the West Europe datacenter, and the result is the same.

Since there is nothing to configure on the Google IdP and the error message does not provide any more info, I really don't know what to do more.




Pedro Felix on Wed, 04 Apr 2012 16:56:55

Apparently, the problem was due to using a RP realm which was not a valid URI. 

Changing the RP realm to a valid URI solved the problem.

Note, however, that none of the admin interfaces produces any error when using a non URI realm.


Arwind - MSFT on Thu, 05 Apr 2012 08:00:21


A similar post from customers,

I've test it at my side and works fine, would you like to test it again? I guess there's something cause interruption.

Hope this helps.