VSGA fails to load VSGLOG file

Category: visual studio graphics tools


Phillip Hamlyn (Peterborough) on Mon, 19 Mar 2018 20:08:10

I have two different W10 Prof installations, both on clean machines, and VS.net 2017 Community. Neither of them can diagnose a VLGLOG file successfully. I have had this issue since VS.net 2015 on earlier machines, so have never managed to debug a frame. I am running a DirectX11 Windows application using SharpDX as the wrapper, in c#.

I can capture frames in the VS.net Diagsession window, but whenever I try to load them VSGA reports the error;

Graphics: The Graphics Diagnostics engine has encountered a fatal error. Please try to reopen the document again, and if the problem persists, please contact the support team.

Windows event log provides the following information

Faulting application name: VsGraphicsDesktopEngine.exe, version: 10.0.16299.15, time stamp: 0x1186d74a

Faulting module name: DXCaptureReplay.dll, version: 10.0.16299.15, time stamp: 0xe89fcc79

Exception code: 0xc0000005

Fault offset: 0x00000000000092f8

Faulting process ID: 0x30ac

Faulting application start time: 0x01d3bfbc32b1b3ac

Faulting application path: C:\Windows\System32\VsGraphicsDesktopEngine.exe

Faulting module path: C:\Windows\SYSTEM32\DXCaptureReplay.dll

Report ID: 494a6436-e64c-42fa-8073-358972ae32b1

Faulting package full name:

Faulting package-relative application ID:

I notice I have two copies of VsGraphicsDesktopEngine.exe

e:\program files\....\VsGraphicsDesktopEngine.exe 15.0.27309.0

c:\windows\system32\VsGraphicsDesktopEngine.exe 10.0.16299.15

The Windows Event Log indicates that its the c:\ version being loaded which seems wrong, but I can't see how to get VSGA.exe to load the 'correct' or more recent VsGraphicsDesktopEngine.exe (assuming that is the error). I've tried uninstalling and reinstalling the Windows 10 Graphics Tools feature but nothing changed. I tried repairing VS.net 2017.

Can anyone help ?