Concurrency Visualizer "The trace is corrupted" error

Category: visual studio parallelcpp


Nikitin Sergey on Sun, 30 Apr 2017 09:17:55

I am trying to use the Concurrency Visualizer tools for MSVC 2015 to analyze concurrency problems in my C++ program.

Unfortunately I always get a "The trace is corrupted" error when I try to parse a generated *.CvTrace file. In the ConcurrencyVisualizer-CVAnalysisService.*.log logs (which I believe generated by trace parsing application) there are a reports about missing "NewThreadId" property (you can view the full log file here). There is indeed no such property in the *.CvTrace xml (you can view it and corresponding *etl file here)

I have tried to gather and analyze reports both via MSVC interface and command-line utility, both with administrator rights and without. My OS is Windows 10 x64, the C++ app I am trying to analyze is also built for x64 architecture.

What can be done to solve this problem?


alex postlethwaite on Thu, 04 May 2017 13:18:56

I'm having the same problem on Windows 10 x64 and the target application I want to profile is also x64.

I see the same errors in the log file:

170504.141550.4701: Error: Exception of Type ParseException
TdhGetProperty failed to retrieve 'NewThreadId' Initial exception during parsing
   at Microsoft.ConcurrencyVisualizer.Common.Support.DoThrow(Exception e)
   at Microsoft.ConcurrencyVisualizer.Common.Support.TraceAndThrow(Exception exception, String text)
   at Microsoft.ConcurrencyVisualizer.Profiling.TraceEvent.TdhPropReader[T](String propertyName, Func`3 rawReader, Int32 index)
   at Microsoft.ConcurrencyVisualizer.Profiling.CSwitchTraceData.FixupData()
   at Microsoft.ConcurrencyVisualizer.Profiling.EtwTraceEventSource.RawDispatch(EVENT_RECORD* rawData)
   at Microsoft.ConcurrencyVisualizer.Profiling.EtwTraceEventSource.RawDispatchWrapper(EVENT_RECORD* rawData)
170504.141550.4711: Error: Throwing exception: TdhGetProperty failed to retrieve 'NewThreadId'

Eric Salem on Fri, 12 May 2017 13:39:44

I also began experiencing this problem recently.  I believe it coincided with a recent Windows 10 update. Has anyone been able to solve it?

cliffski on Sun, 18 Jun 2017 17:17:22

Exactly the same error here, only I'm building a 32bit app. Suddenly this vital tool refuses to work and throws this error. This is INFURIATING. I suspect its the 'creators update' that has screwed up and now stopped me creating stuff...

Louis-Antoine Blais-Morin on Thu, 29 Jun 2017 12:39:30

I had this error message when 

  • generating the trace on a Windows 10 (Enterprise 2016 LTSB)
  • trying to open it on a Windows 8.1 system

However, the same trace opens successfully on another Windows 10 Enterprise system.

Hyunjik Bae on Thu, 03 Aug 2017 03:52:25

I think it is exactly windows 10 creators update issue.

Before Windows 10 creator update, it works. After the update, no. After the rollback, yes.

Degra on Tue, 22 Aug 2017 04:24:23

Do you have the solution? I am also having the same problem too.