Cannot start Metro app on simulator from Visual Studio

Category: windows metro apps tools


DouglasStarnes on Wed, 01 Aug 2012 00:22:35

When I create a Windows 8 Metro app, I am able to run it just fine on the local machine however when I try to debug it on the simulator, the simulator starts and then I get an error saying:

  Unable to start the Simulator.  Cannot process request because the process (####) has exited.

I am using Windows 8 (the latest build, 8400) and VS 2012 RC.  I tried one suggestion I found on the forums about setting a registry key (HKEY_LOCAL_MACHINE_\SYSTEM\CurrentControlSet\Control\Terminal Server\fDenyChildConnections) to 1.  But still no luck.  Has anyone else found a solution to this problem?


sleeping_coelacanth on Wed, 01 Aug 2012 02:04:15


Same Application installed another user account?

Johnny Tordgeman on Fri, 17 Aug 2012 09:39:49

I'm facing the same issue with the RTM version. no matter what i try, the simulation just keeps crashing and my event viewer shows the following error:

"The Desktop Window Manager has encountered a fatal error (0x8898008d)".

I tried searching all over and couldn't find a single solution to the problem. I also tried what you suggested with the fDenyChildConnections but no luck.

Would love to hear if anyone else has encountered this issue and maybe even managed to solve it.

Martin Suchan on Tue, 21 Aug 2012 18:41:40

Same problem here - Windows 8 RTM, VS 2012 Ultimate RTM -> every time I try to start the Simulator I get this:

I looked into eventlog, found this:

"The Desktop Window Manager has encountered a fatal error (0x8898008d)"

I got suspicion that it might be related to nVidia GPu drivers - no drivers were released for Win8 RTM yet.

Johnny Tordgeman on Wed, 22 Aug 2012 10:12:59

I think you are on to something.. when I first installed Windows 8 I had WDM drivers but than I went to NVidia web site and downloaded windows 8 (probably beta) drivers for my graphic card.

In addition, two friends of mine with different laptops (Lenovo and dell) who didn't install any drivers other then what win 8 RTM installed have the simulator working..


I'm happy to say that the latest NVidia beta drivers for windows 8 (304.79) solved the problem! the simulator is finally running as it should :)

Best regards, Johnny Tordgeman.
My Blog

Gerardo Melendrez on Wed, 28 Nov 2012 08:22:25

I had the same problem.

I tried the fDenyChildConnections to 1 and the NVIDIA drivers update solutions but those didn't work for me.

What worked for me is that I realized eventually that having an open connection to my work VPN was causing the problem. So if I close that connection, the problem is solved.

I hope that helps.


Gerardo Melendrez

Dirk A R on Fri, 02 Aug 2013 16:22:31

Well I have also same problem.   Even reinstallation of VS(2013) does not help.

Did indeed start programming on other account.

Installation NVIDIA driver (beta W8.1) does the trick !

Felix Planjer on Sun, 29 Dec 2013 20:58:20

I have the same problem, howevere reinstalling the drivers, reinstalling VS2013 did not work. Still stuck.

Any more suggestions are appreciated.

Ramesh87 on Mon, 06 Jan 2014 05:23:15

I also have the same problem. I re-installed the Windows 8 OS and VS 2012 Pro. Still the issue continues. Anyone has resolved the issue? If so, Please share here.

Winnetka on Mon, 05 May 2014 19:47:04

Not sure if this helps, however, I kept hitting that Simulator button in debug and it suddenly just came up and worked, and it worked great!

I didn't reboot or anything. I thought it might be having 4 screens (2 video cards), but again, it just started.