Access to the path ' ' is denied right on startup

Category: visual studio lightswitch


Ronald Paguay on Fri, 09 Oct 2015 01:58:23

Simple Lightswitch desktop application. External Database is running on SQL Server, Forms authentication enabled.

Problem 1) I have a Concurrency issue. I'm adding entities based upon data in screen in Saving Method, prior DiscardChanges in case actual saving fails. 

Exception has been thrown by the target of an invocation. ---> System.ArgumentNullException: Value cannot be null.
Parameter name: requestUri

I tried to dig in the problem by enabling trace (Msdn Enable Trace Lightswitch), So I switched to Web Client.

Problem 2) When debugging as Web Client, I get the error "File operation not permitted. Access to path '' is denied. " right after IExplorer is open! 

Problem 3) After pressing OK button, I get this error:

Línea: 105
Error: Unhandled Error in Silverlight Application 
Code: 4004    
Category: ManagedRuntimeError       
Message: Se produjo una excepción al establecer la propiedad 'System.Windows.FrameworkElement.Style'.    

The application stops right there, and I'm unable to debug. Please Help!!


Angie Xu on Wed, 21 Oct 2015 09:05:51

HI Ronald,

From your description above, it's a access path issue. Could you provide more information for us? it will help us to troubleshoot.



Ronald Paguay on Mon, 04 Jan 2016 21:45:48

Concurrency issue was solved after deleting IE cache, but the Problems 2 and 3 remain.

Additional information:

1) Web Client crashes, but Desktop Client doesn't.

2) When removed Application Icon, error changed from line 105 to line 109.

3) I guess my project got messy during my early steps when I was trying some extensions, so I removed references to MetroThemeExtension and  ExtensionsMadeEasy installed via NuGet.

4) I've tried to debug in Windows Server 2012 R2 and Windows 8.1 Pro, but got the same error.

5) Updated to VS2013 Update 5, but errors remain.

Please help

Ronald Paguay on Tue, 05 Jan 2016 00:56:11


After painful countless hours found my error!

I had

Public Class Application
        Public Property stupidProperty As String = Environment.GetFolderPath(Environment.SpecialFolder.MyDocuments)
Just wrapped into AutomationFactory.IsAvailable and it worked!