sharepoint "Title" is not showing in EditForm.aspx page in sharepoint Document library

Question

PS_L on Mon, 11 Feb 2013 12:10:30


Hi, The Title Column is not showing in edit form.aspx  for .aspx files .The Title Filed is not showing for Logo pages.aspx files..but the reaming files it will be displaying.. what is probalm for that on

how to enable Title Column in  document library in edit form.aspx.. but  it will be showing some files (.doc,.txt..) but it will not showing an .aspx extension files . it is any problem for .aspx extension files. how to fix it?  In Item (content type) ...






Replies

KIA-SP on Tue, 12 Feb 2013 09:24:07


Hi,

Using the advanced library settings, enable content type management and then set the title field as optional or mandatory instead of hidden.

PS_L on Thu, 14 Feb 2013 12:10:14


Hi,

already we used advanced settings but it will not work..in this document we was upload .aspx Extension pages and providing all properties but Title Field is not showing in Edit form.aspx ..it will displaying in View Properties

KIA-SP on Thu, 14 Feb 2013 13:30:44


You can create a new edit form in sharepoint designer and set that as default and check.

Mecit Semerci on Thu, 14 Feb 2013 15:27:06


Hi 

You can use this tool SharePoint Tips Utility Pack . Check your Title field on Edit Form or create a new Edit Form.

AllenWang on Sat, 16 Feb 2013 12:09:46


Pay attention to the message at the bottom of the EditForm.aspx dialog. It says:

"Open this Web Part Page in maintenance view to delete problem Web Parts and remove personal settings"

This problem is most likely caused by invalid content type of site columns that were added/bind to the document library. The dialog is suppose to display more field, but had problem rendering the fields somehow.

OOBT document library allows your to edit Title column, even if you added a file with extension = ".aspx"

Check the content type and site columns that's bind to the document library.