Question

gnslavov on Tue, 03 Oct 2017 06:43:56


When deploying a Hyperledger fabric from the marketplace an old version of the docker images is used (x86_64-1.0.0-alpha) due to an invalid URL in the configure-fabric-azureuser.sh script.

https://nexus.hyperledger.org/content/repositories/snapshots/sandbox/vex-yul-hyp-jenkins-2/fabric-binaries/release.tar.gz does not exists any more and should be updated to reflect the current structure of the repo.

I am going to manually update the script and re-run the config script to get a working test environment but this should be fixed before we look at this as a viable option for production.


Sponsored



Replies

Microsoft Azure Blockchain Team on Tue, 03 Oct 2017 23:33:39


Hi gnslavov,

We have upgraded the Hyperledger Fabric marketplace templates to v1.0.1. The upgrades should be live this week.

Please let us know if you continue to run into problems after the upgrade takes place!

gnslavov on Wed, 04 Oct 2017 03:51:59


Thank you for the update. Is there any way to know when this goes live other than deploying it? I can't seem to find a template version in the marketplace.

Microsoft Azure Blockchain Team on Thu, 05 Oct 2017 21:47:16


Hi gnslavov,

No problem! To clarify, we have upgraded the Hyperledger Fabric version to x86_64-1.0.1 (v1.0.1). We apologize about the confusion.

We are aiming for this week, however there have been some delays in its release. We will inform you on this thread when the new bits are live.

Hang in there!

Microsoft Azure Blockchain Team on Thu, 19 Oct 2017 18:19:04


Hi gnslavov,

We apologize about the delay!

The updated Hyperledger Fabric template is now available in the Azure Marketplace.

Please let us know if you continue to have issues moving forward.

gnslavov on Wed, 25 Oct 2017 06:21:04


Brilliant, thank you.

We have deployed a local Hyperledger for the moment but will test the Azure template over the next few weeks.