Question

dtwaydd on Mon, 31 Dec 2018 11:56:33


I have set up an IotHub that receives messages from a device. The Hub is getting the messages, and I am able to see the information reaching and being processed in TSI. This is a pay as you go account.

However, when trying to view the data in the TSI enviroment I get a message saying there is no data.

Also, when I try to turn off preview I get a "Fail to get enviroment information"

I also set up a tiered account to test if the issue was the same. Here I was able to see the data and everything was working fine. However I was unable to turn Preview on.

I set up a simple model with hierarchy, types and instances.

Am I doing something wrong?

Thanks in advance

Replies

António Sérgio Azevedo - MSFT on Mon, 31 Dec 2018 12:44:10


Hello diogodtway,

Did you check the following articles to help troubleshoot your issue?

- Applies to TSI Preview: https://docs.microsoft.com/en-us/azure/time-series-insights/time-series-insights-update-how-to-troubleshoot

- Applies to TSI GA: https://docs.microsoft.com/en-us/azure/time-series-insights/time-series-insights-diagnose-and-solve-problems

If so what did you try so far? I have a TSI S1 sku and I could turn the preview on and off just now.

Thanks!


dtwaydd on Mon, 31 Dec 2018 15:20:47


Hello António,

Thank you for the quick reply.

Indeed I can see the data for the S1 Sku in preview. And I now understand that TSI GA does not allow for the creation of models like in the TSI Preview.

My initial goal was to set up a pay as you go account, since it is more appropriate for my solution. I set up a S1 sku mainly to check if the Json data was being imported correctly (Which was confirmed). 

I have tried all of the TSI Troubleshoot options, but still can't get the TSI Preview to show the data. Can you please give me some information about the following:

  - Is there a way to see the imported data in the TSI Preview with pay as you go? With the S1 sku I automatically get the events in the Preview and can query the data immediately. This is not the case for the pay as you go account.

  - Is there an example of how to setup the model in preview? I have consulted the demo for the wind farm, but since I cannot see the Json initial data entry, nor can I see the instances being created, it is hard to replicate the process based on the output solely.

 - Could you please check if the model I created has any problems?
json data arriving

[{ "valores": [{ "voltage": 230.5, "current": 0.051, "power": 0, "frequency": 50, "energy": 1.16, "dvcid": 1, "gway": "SPC-G02", "time": "2018-12-30T21:57:52.8030000Z" }, { "voltage": 230.6, "current": 0.053, "power": 0, "frequency": 50, "energy": 1.16, "dvcid": 1, "gway": "SPC-G02", "time": "2018-12-30T21:57:57.8030000Z" } ], "EventProcessedUtcTime": "2018-12-30T22:02:49.8835362Z", "PartitionId": 3, "EventEnqueuedUtcTime": "2018-12-30T22:02:49.3970000Z", "IoTHub": { "MessageId": null, "CorrelationId": null, "ConnectionDeviceId": "RaspberryPi-Teste1", "ConnectionDeviceGenerationId": "636807313519039605", "EnqueuedTime": "2018-12-30T22:02:49.3960000Z", "StreamId": null } } ]

Since I can't send images or links, I'm sending the Json downloads from the model creation.

Type definition

{"put":[{"id":"d00615a6-a2b7-4ad1-8a6c-7a810e41fcda","name":"Voltage","variables":{"Avg":{"kind":"numeric","value":{"tsx":"$event.[valores_current].Double"},"filter":null,"aggregation":{"tsx":"avg($value)"}}}}]}

Hierarchy

{"put":[{"id":"dc85c034-2a41-4e1f-acfb-17ee9a36e1c4","name":"Site","source":{"instanceFieldNames":["valores.dvcid"]}}]}

Instance

{"put":[{"timeSeriesId":["id001 - voltage"],"typeId":"d00615a6-a2b7-4ad1-8a6c-7a810e41fcda","hierarchyIds":["dc85c034-2a41-4e1f-acfb-17ee9a36e1c4"],"instanceFields":{"valores.dvcid":"1"}}]}

Thanxs

dtwaydd on Wed, 02 Jan 2019 09:27:44


Hello again,

A quick update. In order to further test this issue, I changed the data source to a Device Simulation from https://www.azureiotsolutions.com/Accelerators. 

However, even with the data the chiller template I still get errors displaying time series from the pay as you go model. I can see the events coming in, but whenever I choose a series to display it displays a message saying there is no data.



António Sérgio Azevedo - MSFT on Wed, 02 Jan 2019 15:17:35


Hi Diogo,

Can this tutorial help with what you are trying to achieve?: https://docs.microsoft.com/en-us/azure/time-series-insights/time-series-insights-update-create-environment

See here how to define and apply a model on Azure TSI Preview.

Thanks!

dtwaydd on Wed, 02 Jan 2019 23:43:45


Hello António,

I had gone thru all of the documentation already. 

Finally I found the error in my setup. The "Time Series ID Property" was incorrectly assigned, there was no field in the data with the property I had inserted.

As you can see in the image of my previous post, the timeline on the preview was showing events coming in, but the series showed a "This time series contains no data" error. Fixing the Time series id property and rebuilding the service solved the problem.

If I could make a suggestion, you should add a picture with the effects of an incorrect Time series ID property in the troubleshoot article. It would make it clearer of when the setup has this error. 

Thank you for your help.