Question

Jyothiv on Mon, 28 Nov 2011 05:26:36


Hi,

 

I am getting below error while executing the Replay.

C:\Program Files (x86)\Microsoft SQL Server\110\Tools\Binn>DReplay replay -m xxxxxx_controller -d E:\MSSQL11.MSSQLSERVER\ -o -w YYYYYY_client -s zzzz_target

2011-11-27 13:29:45:705 Error DReplay   The client 'YYYYYY_client' is not a registered distributed replay client. Make sure that the SQL Server Distributed Replay Client services is running on 'YYYYYY_client', and that the client is registered with controller 'xxxxxx_controller'.

 

Distributed Replay Client services is running state and these are running under domain account not the local account

 

Here are the config settings on YYYYYY_client in C:\Program Files (x86)\Microsoft SQL Server\110\Tools\DReplayClient\DReplayClient.config

 

<?xml version="1.0" encoding="utf-8"?>

<Options>

  <Controller>xxxxxx</Controller>

  <WorkingDirectory>E:\MSSQL11.MSSQLSERVER\WorkingDir\</WorkingDirectory>

  <ResultDirectory>E:\MSSQL11.MSSQLSERVER\ResultDir\</ResultDirectory>

  <LoggingLevel>INFORMATION</LoggingLevel>

</Options>

 

Not sure what I am missing in controller side.  In any configs in the controller do I need mention the clients.

 


Sponsored



Replies

Jyothiv on Thu, 01 Dec 2011 20:40:32


its resolved by adding these permissions

 

DCOM CONFIG -- (in cmd type dcomcnfg.exe)

Component services --> my computer --> Dcom config --> DreplayController --> properties -->Security

                                                                          --> Launch and activate permission -->edit  --> add service account full permissions

                                                                           --> Access Permissions --> edit --> add service acocunt full permissions

                                                                          --> Configuration permission -->Edit --> add service account full permissions

Computer -->my computer  --> comsecurity -->  access permission --> edit and add  the service acocunt

                                          --> Launch and Activate permission --> edit and add the service account

local security policies -- added my account as log on services and service account