VS 2012: Find in Files returns no line item results.

Category: c# ide

Question

Joseph Buys (TS) on Tue, 02 Oct 2012 20:13:40


Hello,

When I search for anything using the "Find in Files" (Ctrl-Shift-F), it searches everything, finds results, but does not list the individual files or where it found the results.  Here is the screenshot:


It teases me by telling me "Yes, I found 2 results for you, but no, I will not tell you where they are."

I know this has been asked before for previous versions of VS and there have been "Answers" posted for this.  However, I have followed ALL of those posts and suggestions and none of them seem to work.  Here is what I have tried...

1. Resetting the defaults with Import/Export Settings
2. Changing the registry settings for Find In Files
3. Changing the options for Find in Files (output to another window)
4. Trying all sorts of combinations of Ctrl+SrlLock and Ctrl+Break etc etc.
5. Rebooting
6. Repairing installation.

This error REALLY cuts into productivity and was wondering if anyone else has an idea of how to fix this.  It's hard to believe that a single simple feature like Ctrl-Shift-F will have you wanting to completely reinstall your machine to get it working again!

Thanks,
~Joe


Replies

Reed Copsey, Jr on Tue, 02 Oct 2012 20:17:26


Does the same thing happen if you do a search that returns a reasonable amount of results?  I suspect there may be an optimization that prevents VS from locking up the UI trying to display 62310 matches....

What happens if you search for something where there are only a couple hundred matches?

Joseph Buys (TS) on Thu, 04 Oct 2012 05:16:20


Hello Reed,

This happens whether I find 1 result, or 50000 results.  It makes no difference.  The "Find All References" correctly works, but I know that is using a different searching algorithm.

Any ideas?

Thanks,
~Joe

Lisa Zhu on Thu, 04 Oct 2012 09:04:07


Hi Joe ,

How do you get this problem ?

I can't reproduce this problem , I am curious when does this happen ?
Does it show  after installing  VS2012 or after you doing something .

If it shows after you doing something , can you provide the steps ?

Thanks,


Lisa Zhu [MSFT]
MSDN Community Support | Feedback to us


CoolDadTx on Thu, 04 Oct 2012 14:21:11


I'm concerned that your "change registry entries for Find..." might be making things worse.  Have you tried running in safemode (/safemode) to eliminate any third-party components?  Also check the ActivityLog.xml to see if there are any errors.  It is under Roaming\Microsoft\VisualStudio\11.0

Michael Taylor - 10/4/2012
http://msmvps.com/blogs/p3net

Joseph Buys (TS) on Thu, 04 Oct 2012 20:37:48


I don't know how to reproduce the problem -- it started after I installed VS2012 (RTM).  It was working fine in VS2010.  I can't get a repro because I can't get it to be fixed.  I only played with the registry (I backed up and restored everything properly when that didn't fix things).  Nobody else in the office could figure it out either -- probably 5 different people looked at it and thought it was extremely bizarre. 

But no need to think about this any further -- I reformatted and rebuilt the machine. I couldn't handle not being able to find things in my solutions (and going to the cmd line and using findstr became more and more frustrating).  Now it works fine.

~Joe

Lisa Zhu on Fri, 05 Oct 2012 06:21:28


Hi Joe ,

Glad to know that you will not not be botherd by this weird problem .

Have a nice day!

Regards,

Sca_Tone on Thu, 25 Oct 2012 15:06:21


I am also getting the same problem as Joe.
It is happening in safemode so it cannot be third party component.

I am unable to rebuild the machine to see if it goes away, so need to get this sorted.
This is a brand new machine that was built with only VS2012 (no other VS versions installed).

Any help would be appreciated.

Gonemad83 on Thu, 01 Nov 2012 03:55:35


Also having the same problem.  Reformatting/Reinstalling is obviously not a viable solution.

This only just started happening out of the blue.  Was working fine a couple of days ago... doubt that helps, but there ya go

Stephen Drew on Mon, 12 Nov 2012 22:08:01


I have something similar where Find/Replace in Files just refuses to find all the results.  A regular find/replace works if one has the patience to press Replace a couple of hundred times.

It's immensely frustrating as I have come to rely on this functionality so much that I assume it is always working.

It seems like such a basic piece of functionality, yet it has had bugs in every version of Visual Studio since at least 2008.

Max J Barfuss on Wed, 14 Nov 2012 17:53:14


This is an extremely frustrating problem.  Is there a log entry we can look at to help troubleshoot it?  It is obviously happening to quite a few people.  Mine (coincidentally?) started happening just after upgrading my Resharper verison from 7 to 7.1.  

-Max

CoolDadTx on Wed, 14 Nov 2012 18:24:14


The defacto troubleshooting option is to run in safe mode (/safemode) to eliminate any extensions from getting in the way.  If the problem goes away then it is an extension otherwise it is VS.

Michael Taylor - 11/14/2012
http://msmvps.com/blogs/p3net

Jafin on Fri, 16 Nov 2012 06:38:58


EDIT: Installing Visual Studio 2012 Update 1 has resolved the problem in my case.

For me neither safemode or resetsettings have resolved the find returning no values.

Jafin on Fri, 16 Nov 2012 06:49:57


EDIT: Installing Visual Studio 2012 Update 1 has corrected the problem in my case.

Other than reformatting or trying the above mentioned fixes are there any further options to resolve this problem?