Question

vchk_awe on Wed, 29 Nov 2017 07:56:25


Recently we are installing Moodle in Azure web app using Azure Database for MySQL, it requires the setting innodb_file_per_table to set to 1.

However, our admin account do not have privilege to change this setting, can you advise how we can change this setting? Or otherwise we cannot use this Azure service.

I notice that there is a similar issue raised before in this forum, Microsoft please pay attention to this. Thanks.

https://social.msdn.microsoft.com/Forums/en-US/736d6efa-a8cd-4d74-a68a-50e2c21313c5/azure-database-for-mysql-innodbfilepertable-setting?forum=AzureDatabaseforMySQL


Sponsored



Replies

JasonHowell on Wed, 29 Nov 2017 09:02:16


The only options that can be set at present are in the Azure portal on the Server parameters page under your server. https://docs.microsoft.com/en-us/azure/mysql/howto-server-parameters

I couldn't get in tonight to look if this option is available, but have a look if you are there.

Thanks, Jason

vchk_awe on Wed, 29 Nov 2017 09:49:29


The setting innodb_file_per_table is not available in the Server Parameters section, is there any way to change it?

Jason M. Anderson on Thu, 30 Nov 2017 17:31:50


Server Parameters that are not exposed are preset and documented here - https://docs.microsoft.com/en-us/azure/mysql/howto-server-parameters 

For all other parameter values, such as innodb_file_per_table, are set to their default.  In MySQL 5.7 this is already set to "1" so you should be fine installing Moodle.

vchk_awe on Mon, 04 Dec 2017 07:51:32


Checked the server setting, the innodb_file_per_table is still OFF for our mysql 5.7 database.

https://social.msdn.microsoft.com/Forums/getfile/1177222