Question

Vince P on Thu, 24 Apr 2014 06:40:26


SharePoint 2013, SQL Server 2012 Sp1

Installed PowerPivot. had problems during the installation and had to run all scripts from Create PowerPivot Service Application to the end manually.

The dashboard page keeps throwing up prompt for user credentials and in the main "Server Health" area there's a dialog-box looking error that says "Excel Services. We're sorry. We ran into a problem completing your request. Please try again in a few minutes"

So freaking helpful!

Any ideas how to get this house of cards to work?



Sponsored



Replies

Vince P on Fri, 25 Apr 2014 14:52:55


No ideas? Sigh.

Vince P on Sun, 27 Apr 2014 19:10:34


So I decided to install a new farm on some virtual servers.  During the Configuration of Power Pivot I got the same error again that I did the last time.  The last time this happened, I manually looked at all the scripts the config tool used and was able to get them to run. 

This is the log: (In the PowerPivot Config Tool) for step Create PowerPivot Service Application. This looks very similar to the errors that got me to write this post for help in the first place.

27/04/14 13:50:38:7541 Verbose: CreateServiceApplicationInstance.NeedsExecute

27/04/14 13:50:38:7551 Verbose: Running function IsFarmConfigured to check whether SharePoint is configured regardless of availability

27/04/14 13:50:38:7551 Verbose: Farm is configured

27/04/14 13:50:38:7551 Verbose: Running function IsServiceApplicationInFarm()

27/04/14 13:50:38:7551 Verbose: Entering function GetService(Guid)

27/04/14 13:50:38:7551 Verbose: Service is not installed.

27/04/14 13:50:38:7551 Verbose: Did not find System Service

27/04/14 13:50:38:7551 Verbose: CreateServiceApplicationInstance.NeedsExecute(True)

27/04/14 13:50:38:7551 Verbose: CreateServiceApplicationInstance.CanExecute

27/04/14 13:50:38:7591 Verbose: Testing that parameters are not null or default values

27/04/14 13:50:38:7601 Verbose: Parameter name: Service Application Name, value: Default PowerPivot Service Application, default value: <Service Application Name>

27/04/14 13:50:38:7601 Verbose: Value (Default PowerPivot Service Application) for parameter (Service Application Name) is set.

27/04/14 13:50:38:7601 Verbose: Parameter name: Database Server, value: eval-sp2013sql, default value: <Database Server>

27/04/14 13:50:38:7601 Verbose: Value (eval-sp2013sql) for parameter (Database Server) is set.

27/04/14 13:50:38:7601 Verbose: Parameter name: Database Name, value: DefaultPowerPivotServiceApplicationDB-b8b55dc3-14a1-452d-8982-fd8e11314a9a, default value: <Database Name>

27/04/14 13:50:38:7601 Verbose: Value (DefaultPowerPivotServiceApplicationDB-b8b55dc3-14a1-452d-8982-fd8e11314a9a) for parameter (Database Name) is set.

27/04/14 13:50:38:7731 Verbose: CreateServiceApplicationInstance.CanExecute(True)

27/04/14 13:56:36:6275 Verbose: CreateServiceApplicationInstance.Execute

27/04/14 13:56:36:6295 Verbose: Create PowerPivot Service Application

27/04/14 13:56:36:6295 Verbose: Configuring new SharePoint farm

27/04/14 13:56:36:6295 Verbose: Application base: C:\Program Files\Microsoft SQL Server\110\Tools\PowerPivotTools\SPAddinConfiguration\Bin\

27/04/14 13:56:36:6355 Verbose: Execution Assembly for new AppDomain: Microsoft.AnalysisServices.SPAddin.Configuration.Proxy, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91:

27/04/14 14:01:55:7193 Verbose: Return value: False

27/04/14 14:01:55:9523 Verbose: CreateServiceApplicationInstance.Execute(Failed)


Failure while running action: Create PowerPivot Service Application

27/04/14 14:01:55:7463 High: Failure

27/04/14 14:01:55:7463 High: Object '/baf52ff9_803d_4870_8847_ca6a17263f50/elfwes9zoa1d9a52xfijk0ot_21.rem' has been disconnected or does not exist at the server.

27/04/14 14:01:55:9523 High: Exception while executing action CreateServiceApplicationInstance: Object '/baf52ff9_803d_4870_8847_ca6a17263f50/elfwes9zoa1d9a52xfijk0ot_21.rem' has been disconnected or does not exist at the server.

Vince P on Tue, 29 Apr 2014 01:52:23


I guess I'm just talking to myself here.   Oh well that should answer my question as to why I'm even bothering with this entire experience of frustration.

Thanks.

Darren Greenberg on Wed, 07 May 2014 13:51:34


I guess I'm just talking to myself here.   Oh well that should answer my question as to why I'm even bothering with this entire experience of frustration.

Thanks.

If it's any consolation I'm seeing the same exact problem on my farm. If I get anywhere with it I'll update...

Vince P on Wed, 07 May 2014 15:56:44


Well I was able to figure out the sequence of powershell commands. So I ran them one by one and managed to complete the installation... though the Power Pivot Dashboard on Central Admin still is broken.  Everthing else seems to be working.  If I ever solve this, i'll make sure to update this page.