Question

DesertKat on Fri, 25 Dec 2015 17:25:01


I had to rebuild my laptop. I reinstalled Visual Studio 2012 on my Windows 8.1 OS. This used to work just fine, but now I can run my .Net MVC4 website. Here is the error I get for every .rdlc in the project. "An unexpected error occurred while compiling expressions. Native compiler return value: '-1073741511'  This project runs fine on my Windows 7 OS with the same VS2012.  I googled my error and many said it had to do with the .Net framework.  So I upgraded that too, but still receive the error.

 



Sponsored



Replies

Weiwei Cai on Tue, 05 Jan 2016 08:18:20


Hi DesertKat,

Please create a new project with Visual Studio 2012 on Windows 8.1 to check whether this problem is occurs with this specific project or all projects.

If just this specific project, please move the project files one by one to the new project to confirm which file causes this problem. And then add the controls and code one by one into this file to make sure which controls and line of code causes this problem.

If for all projects, please make sure whether it is related to corrupted .net frameworks, please take the following steps to see if it helps:

1. You can try run “SFC /scannow” to repair the embed .NET first, refer to:  https://support.microsoft.com/en-us/kb/929833

2. Use .NET Framework Setup Verification Tool to verify the .NET Frameworks on your machine, you can download from here: http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

By using it, you will find the log file under %TEMP% folder, see the first 15 lines and the last 15 lines.

If the exit code != 0, it means that your .NET installed incorrectly, please first use .NET Framework Repair Tool to repair it, http://www.microsoft.com/en-us/download/details.aspx?id=30135

In addition, please compare the .NET Framework between your Windows 7 and Windows 8.1. Make sure they are installed the same version of .NET Framework. Because there are any differences between every .NET Framework. 

Best Regards,
Weiwei

Saba_M on Mon, 18 Jan 2016 12:01:04


I got the same RDLC error even after upgrading the .NET framework. Came across one more thread: 

(Copy this link and paste it in address bar, For some reason I am unable to submit text with links. Removed the hyperlink)

https://social.msdn.microsoft.com/Forums/en-US/b7d6816f-bcfd-4278-824e-e3bd653f85fa/rdl-from-ctp-30-does-not-work-with-ctp-32?forum=SQLServer2016Preview&prof=required


Here is my reply for the same thread: 

I was using RDLC, I got the same error. I had two things in the footer, execution time and page number. I removed execution time and the error was still there. I removed page number this time and it worked. I can see the report getting displayed now without any errors. :/ I am not sure what's the problem if we use execution time/page number or anything in the footer. 

Will try to find out why is the footer causing issues.. Meanwhile give this a try..