Question

Sanban on Sat, 20 Mar 2010 08:58:36


Initally when I try to import a spreadsheet to SharePoint-2007 Portal? It gave me the following error:

Method ‘Post’ of object ‘IOWSPostData’ Failed

As suggested many of the blogs and SharePoint Fourms, I have updated my machine's C:\Program Files\Microsoft Office\Office12\1033\EXPTOOWS.XLA file with value  lVer = 2.

Now I'm getting the following error

Method 'Publish' of object "ListObject failed.

Though the list is getting created on SharePoint site but spreadsheet data is not being copied. The same problem is mentioned in this post(http://doolbox.blogspot.com/2008/07/method-publish-of-object-listobject.html)

All the users are getting one of the above two error. So this means there is problem on SharePoint server side not in the clinet side?? 

Has anybody got any solution for this?

Thanks in advance.

San

Env: SharePoint 2007 with SP1

Client: Office 2007/2003(not both)

 

 

Replies

Rock Wang– MSFT on Mon, 22 Mar 2010 09:23:04


Hi Sanban,

 

Did you use FQDN or not? If you use FQDN, check whether you add the FQDN to the intranet sites zone. If not, try to correct it and reboot the client machine after making this change which suggests some sort of caching that was going on in the environment. Finally check the effect.

 

if the user only selects the rows a range is specified like $1:$1. Try to select the entire range of data to be imported including the rows and columns. This should look like $A$1:$D$3.

 

In addition, you can refer to the following article to fix the issue:

Description of the Excel 2007 hotfix package (Excel-xx-xx.msp): August 26, 2008

http://support.microsoft.com/kb/956510/en-us

 

Hope this helps.

 

Rock Wang

Sanban on Mon, 22 Mar 2010 13:49:13


Thanks Rock Wang for your reponse..

I have already installed 956510 patch for Excel-2007. This actually updates this 1033\EXPTOOWS.XLA file.

This is an intranet site with SSL and  I have added FQDN to my trusted sites list in IE 8.0.

I also tried selecting the whole data in spreadsheet, but still it fails. As this behaviour is same for all the users, so I'm thinking this could be an issue on the server side and nothing to do with client machine. Any other inputs??

Thanks,

San

 

Rock Wang– MSFT on Tue, 23 Mar 2010 03:48:44


Hi Sanban,

 

Check whether you have created a top level site or not. If not then just create the top level site and check the effect. For example you site's address where you are importing the Excel SpreadSheet will be like this "http://servername/sites/sitename". Now check that the top level site means a site at url "http://servername" is created or not. If not then just create the top level site at "http://servername" and try again to import the Excel SpreadSheet.

 

How did you edit EXPTOOWS.XLA file? Please make sure your steps are correct according to the following steps:

 

To edit the file, just double click on it. It should open in Excel. Hit the Alt + F11 keys to open the file in Visual Basic Editor.

 

If you are only creating custom lists via spreadsheets on WSS v2 or higher, you can search the project for Application.SharePointVersion and change:

lVer = Application.SharePointVersion(URL)

to:

lVer = 2

 

[this is in the 'Sub Initialize' routine of the publishForm module (Code section)]

 

Hope this helps.

 

Rock Wang

Sanban on Wed, 31 Mar 2010 17:38:02


Thanks Rock for replying, sorry for late in responding to your query

yes we do have a root website, so I can browse the site using https://sitename.domain.org, but I have not tested importing the excelsheet on root website.

Yes I followed exactly the same steps you have mentioned here to update the EXPTOOWS.XLA file. But same problem .. I'm looking for a solution on sharepoint server side .

 

WYLIESHADOW on Mon, 05 Apr 2010 18:27:34


I'm having the same issue with this error:  Method ‘Post’ of object ‘IOWSPostData’ Failed.

I am unable to edit the EXPTOOWS.XLA file. when i double click/or choose open into excel, excel opens but with no file and no options other than new/open.

I've also tried changing extension to .xls and I get the same nothingness.

I would have thought opening it up in Visual Studio would work but it still looks pretty crazy with some small parts of readability.

I'm wondering if i may be in another world of issues due to my software versions. 

-Windows 7

-Microsoft Office Pro Plus

-MOSS2007


Sanban on Tue, 06 Apr 2010 13:24:59


Hi WYLIESHADOW,

To edit EXPTOOWS.XLA, after you open the excel file, press alt+F11, this will open the Visual basic editor.

I'm still having this issue, no solution yet

 

gare2 on Fri, 16 Aug 2013 16:37:51


I encountered this error:  

Method 'Publish' of object "ListObject failed. 

when trying to import from spreadsheet a 4x3000 Excel table into SharePoint 2010.

My Solution was to Import as Range of Cells instead of Table Range.

hth someone.

Eda N on Wed, 12 Jul 2017 23:56:52


The issue is caused by merged cells on the Excel spreadsheet. If you only have a couple, un-merging the cells and manually entering the data after importing should do the trick.