Question

Global Software Resources on Fri, 27 Jul 2012 06:17:20


If am developing the Web role application publishing and deploying its working fine. If am applying caching(preview) The webrole is not yet deployed and web role is cycling for a long time and it shown the unhandled exception at that time of deploying in azure.Its working fine at local.. I wants to see the remote machine event logs to see the appropriate error. If am connect the remote machine of the Web role instance, The following error message shown:

Remote Desktop can't connect to the remote computer for one of these reasons:

1. Remote access to the server is not enabled.

2. The Remote computer is turned off.

3. The Remote computer is not available on the network.

Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.

Solution to the error message to connect to the remote logs and find the event logs of the azure application.

Replies

Arwind - MSFT on Fri, 27 Jul 2012 09:06:30


Hi,

It seems your Remote Desktop is not working in cloud environment, and the cloud application also cloud not be works? You says you can got "unhandled exception", what exception did you get? Would you like to share them? I've tried deploy a simple web role application but unfortunately cant reproduce your problem.

If you deploy the same application with another hosted service, does the same issue will be occurred?

You can also enable intelli trace to collect more information and share your code to help us fix the problem.

Hope this helps.

Veerendra Kumar on Fri, 27 Jul 2012 11:26:58


What i see here is, you web role provisioning itself is failed. If you the role is not yet up and running it is not possible to TS into the azure VM.

Can you post more details? have you tried removing cache role and deploy the webrole alone again?

Please share the results and more details of the problem.