Question

AlexLeo1 on Fri, 18 Apr 2014 15:06:30


Good day.

We have Windows Server 2008 R2 Enterprise X64 and SQL SERVER 2005

Also we install php5.4 VC9 x86 Non Thread Safe and sqlsrv for this version.

When we make connect to server we get error:

    Array
    (
        [0] => Array
            (
                [0] => IMSSP
                [SQLSTATE] => IMSSP
                [1] => -49
                [code] => -49
                [2] => This extension requires the Microsoft SQL Server 2012 Native Client. Access the following URL to download the Microsoft SQL Server 2012 Native Client ODBC driver for x86: http://go.microsoft.com/fwlink/?LinkId=163712
                [message] => This extension requires the Microsoft SQL Server 2012 Native Client. Access the following URL to download the Microsoft SQL Server 2012 Native Client ODBC driver for x86: http://go.microsoft.com/fwlink/?LinkId=163712
            )
    ...

As we can see need install Microsoft SQL Server 2012 Native Client ODBC driver for x86 but when we have system x-64 and when we start installer we get error that installer x86 is not suitable for my operation system(for x64).

Anybody know what we should do for close problem?

P.S.: 

**link on phpinfo - `http://194.58.88.58/test.php`** 

 **link on error `http://view-source:http://194.58.88.58/`**

Sponsored



Replies

Tom Phillips on Fri, 18 Apr 2014 15:42:27


The message is incorrect.  It should not reference the x86 version.  You need the x64 version.

Please see:

http://social.msdn.microsoft.com/Forums/sqlserver/en-US/df2caeac-f57f-462e-be7c-f51f46deff0e/this-extension-requires-the-microsoft-sql-server-2012-native-client-access-the-following-url-to?forum=sqldriverforphp