Question

Praveen N H on Sun, 08 Jan 2017 23:40:11


Copy Salesforce to Azure Table.

When I tried to create a Copy activity using Azure power Copy tool Schema for Salesforce table is not loaded. I am getting following error.

"Error when processing request: Specified cast is not valid. activityId: c1427c14-e9b3-4046-bb3e-ac862cea3021"

This was not happening until recently. And we have not changed anything at source Linked service.

Can you please help?

Thanks in Advance.





Sponsored



Replies

Charles Gu on Mon, 09 Jan 2017 10:28:07


Hi, Praveen

So, this source can be loaded in copy tool before. Is it right? Does existing pipeline copy correct?

Is the issue on "Preview", "Schema", or both?

I will check the others whether we have any code change and then back to you.

Thanks,

Charles


Praveen N H on Tue, 10 Jan 2017 05:38:29


Hi Charles,

Yes, This was working until last Saturday!

This happens only on Schema.... For every Salesforce Object/table. 




Mouadh JOMAA on Tue, 10 Jan 2017 11:47:21


Hello Everyone,

I am actually experiencing the same issue as Praveen !

I am testing the import of data from Salesforce to Azure SQL Database using Data Factory. In the DataSet level, Preview works fine but the Schema is not loading and is sending this error : "Error when processing request: Specified cast is not valid. "

Are there some known work arounds regarding this matter ?

Thanks for you answers.

Mouadh JOMAA

Nagendrababu on Wed, 11 Jan 2017 13:19:19


Hi Charles, Is there a work around or solution for this issue, this issue has caused lot of inconvenience to our client. Even we are facing same problem, could to please respond soon. Thanks a lot. Regards Nagendrax

Charles Gu on Fri, 13 Jan 2017 02:27:38


Sorry for reply delay. This is an regression issue on UX and we have a hotfix on 1/11. Now issue should be resolved and we will discuss how to avoid such issue next time.

Charles Gu on Fri, 13 Jan 2017 02:28:28


Thank you and sorry for reply delay. We have a hot fix on 1/11, and you can retry.

Charles Gu on Fri, 13 Jan 2017 02:29:19


Thank you and sorry for reply delay. We have a hot fix on 1/11, and you can retry.

Praveen N H on Sun, 15 Jan 2017 00:50:32


Thanks Charles.

I saw it and I could mange to continue . Its Working now.