Provision using Add-AppxProvisionedPackage

Category: windows apps - submitting and publishing

Question

rajashanmugam on Wed, 14 Aug 2019 11:36:55


Hi,

I am installing UWP app using below command 

>Add-AppxProvisionedPackage -PackagePath "D:\Apps\testapp.appxbundle" -LicensePath "D:\Apps\license.xml" -Online

For Windows 10 OS Version 1607 and below(1511)

For first time, the app gets installed successfully and when i remove the app using 

>Remove-AppxProvisionedPackage -PackageName "NameOfPackage"  -Online

It removed successfully.

And when i tried to provision again with a higher version of the app using the same Add-AppxProvisionedPackage command, the command is executed successfully but the app is not visible under start menu or in Settings>Apps&Features.

From OS Version 1703 and above the issue has not been observed, its only happening in 1607 and below.

why i could not able to see the app in start menu ?


raja

Replies

Daisy Tian on Thu, 15 Aug 2019 09:41:24


Hi raja,

Did you manually package your project as appxbundle? Or is it packaged with Visual Studio? If it is packaged with VS, have you ever tried double-clicking your testapp.appxbundle to install your app(should install the certification before installing the app)?You could refer to the later part of this Blog for the installation steps. Could the app installed in this way be displayed in your Start menu?

Best regards

Daisy  Tian

rajashanmugam on Fri, 16 Aug 2019 04:54:00


Hi Daisy  Tian,

My app has been already uploaded to store and i use the .appxbundle from the preinstallkit.

now i am trying to install the .appxbundle using below command.

>Add-AppxProvisionedPackage -PackagePath "D:\Apps\testapp.appxbundle" -LicensePath "D:\Apps\license.xml" -Online

If i install normally using >Add-AppxPackage "PackageName" i can able to see the app in the start menu.

The issue is if i use the Add-AppxProvisionedPackage cmd (For Windows 10 OS Version 1607 and below(1511) if i install it for second time)

Daisy Tian on Thu, 22 Aug 2019 03:11:49


Hi raja,

There is no much difference between the way Add-AppxProvisionedPackage and Add-AppxPackage install the app, just a difference in the use of new user. Did you restart the computer to see if the app exists in the start menu?

Best regards

Daisy Tian