Invalid Certificate issues

Category: azure cdn

Question

Tamas Szucs on Mon, 25 Feb 2019 15:58:50


Hi,

I'm hosting my site using the static site host service on Azure Blob Storage, with Verizon Premium cdn to enable HTTPS connection for my custom domain (I use Azure App Service domain and DNS zone). I submitted for an automatic DigiCert certificate for my custom domain, but it generated an invalid certificate.

This is the error I get in Chrome:

This server could not prove that it is www.<mysite>.com; its security certificate is from sni.msft.default.wpc.edgecastcdn.net. This may be caused by a misconfiguration or an attacker intercepting your connection.

What should I configure differently? My current setup is the following:

CDN Endpoint custom domain hostname:

www.mysite.com

DNS setting:

*.mysite.com -> mycdnendpoint.azureedge.net

www.mysite.com -> mycdnendpoint.azureedge.net

I also have the following http to https rewrite rule enabled::

  <feature.url-redirect code="301" pattern="/80A7DDD/mycdnendpoint/(.*)" value="https://%{host}/$1" />

Thanks,

Tamas



Replies

Tamas Szucs on Mon, 25 Feb 2019 18:33:12


It seems passing time solved the issue, it works correctly now. Few hours later than the custom https process completed, it may be worth mentioning in a notification.

SubhashVasarapu-MSFT on Wed, 06 Mar 2019 11:21:14


@Tamas, Thanks for reporting this issue and update. Glad it's working fine. Kindly do let us know if you need any further assistance. You can always share your feedback with us using uservoice.