Question

Benjas_lee on Wed, 15 Nov 2006 04:31:23


Hi,

I run openquery() from a client application(sql 2005) to query SSAS data(sql 2005) through a linked server(sql 2005), but I get the following error:

OLE DB provider "MSOLAP" for linked server "LINKEDMINING" returned message "An error was encountered in the transport layer.".
OLE DB provider "MSOLAP" for linked server "LINKEDMINING" returned message "The peer prematurely closed the connection.".
Msg 7303, Level 16, State 1, Procedure gettpdt, Line 3
Cannot initialize the data source object of OLE DB provider "MSOLAP" for linked server "LINKEDMINING".

And, I am sure that I have made the MSOLAP provider Allow inprocess.

What can i do for this. Please advise.


Sponsored



Replies

Bogdan Crivat on Thu, 16 Nov 2006 07:12:58


Can you connect to Analysis Services directly from SQL Server management studio, from the same machine as SQL Server?

Benjas_lee on Sat, 18 Nov 2006 12:57:16


hi,

I have solved this problem, thank you

Mafti on Mon, 12 Mar 2007 15:47:04


how did you solve it?

DanMeyers on Sat, 31 Mar 2007 20:52:48


How did you solve this problem?

Benjas_lee on Wed, 04 Apr 2007 04:23:28


add the server as trusted server in Active Director

 

 choose the option 'trust computer for delegation'

maeenul on Wed, 26 May 2010 03:09:16


Although the post is very old, I am a just posting a link so that future users can get some help. I hope this might resolve the problem for some users.

http://blog.programmingsolution.net/ssas-2008/retrieve-ssas-cube-data-in-tabular-format-from-stored-procedure-using-linked-server/

 

Aravind Kamath on Wed, 21 Mar 2012 15:40:56


Thanks Maeenul; 

http://blog.programmingsolution.net/ssas-2008/retrieve-ssas-cube-data-in-tabular-format-from-stored-procedure-using-linked-server/ link helped me to resolve the issue.

Aravind

NareshRavula on Thu, 01 Nov 2012 06:15:29


Hi maeenul,

I visited u'r blog and its good, but if i proceed with that solution then i'm getting error : Microsoft SQL Server: Error 7373

Please suggest me in this.

Thanks and Regards,

Naresh Ravula

Peterson S Duarte on Mon, 03 Dec 2012 15:28:49


Hi everyone,

I have same problem. Can you help me?

I can create linked server only by command line with

EXEC sp_addlinkedserver
@server= ‘OLAPAS’,
@srvproduct=”,
@provider=’MSOLAP’,
@datasrc=’DOMAIN\SERVER’,
@catalog=’NAMECATALOG’

but when I try to grant permissions to the user DOMAIN\USER these errors appear:

OBS: I’ll transcribe the content of message box SSMS

The linked Server has been update but failed a connection test. Do you want to edit the linked server properties?

Aditional Information

-> An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)
-> The OLE DB provider “MSOLAP” for linked server “OLAPAS” reported an error. The provider did not give any information about the error.
Cannot set the initialization properties for OLE DB provider “MSOLAP” for linked server “OLAPAS”. (Microsoft SQL Server, Error: 7399)