Question

RichardHardy on Thu, 13 Oct 2016 12:14:29


I've installed the Power BI Twitter Template, but it's not processing Tweets. 

Everything seems to be correctly set up, but i get an error trying to monitor the Function App that has been set up. 

I guess it's not running and thats why my DB isn't recieving any info. 

This is the error in Azure when trying to monitor the Function App: 

You may be experiencing an error. If you're having issues, please post them

Session Id: d6d81ae950fe46dd93e41ff4f230c084

Timestamp: 2016-10-13T12:02:55.257Z


Sponsored



Replies

tiger_wang21 on Thu, 13 Oct 2016 13:23:52


we have got the same issue. any resolution?

tiger_wang21 on Thu, 13 Oct 2016 13:27:35


 Session Id: 8a0ed1c3781144bfa640f773d6624e37

Mike Stall - MSFT on Fri, 21 Oct 2016 20:58:48


FYI, folks are investigating this. This appears to be a 500 coming from the Function monitoring APIs. The APIs are at https://github.com/Azure/azure-webjobs-sdk/blob/master/src/Dashboard/ApiControllers/FunctionsController.cs and running in the AzureJobs site extension on the site.  

I've filed https://github.com/Azure/azure-webjobs-sdk/issues/879 to track this.

Sisira Panchagnula on Fri, 21 Oct 2016 21:06:29


Thanks for reporting this issue. We are investigating this issue and will get back to you once we have more details.

Sisira Panchagnula on Fri, 21 Oct 2016 21:25:29


how was the Function App created? Did you use the Azure portal?

 We noticed that the App is missing some vital settings that are needed for the Function App to work as expected - this is causing the Monitoring APIs to fail.

Donna Malayeri on Thu, 03 Nov 2016 02:52:57


We followed up on this, and discovered that there was a configuration error in the Power BI twitter template. We've followed up with them and they are fixing the template.