Question

Sigge Persson on Mon, 21 Aug 2017 14:29:22


This regards sharepoint designer 2013 but used in a sharepoint 2016 on premise site after an in place upgrade

I get the same issue as in this question

But for me, rebooting the server does not help, neither does restarting the cache cluster.
The error is always there 

Sharepoint designer has worked earlier in another deployment of the site.
It also works in the production enverinment.
But some change done on the server during redeploys (this is a test environment) has introduced this behaviour.

Everytime i try to connect to a site with sharepoint designer i get the popup message
"The server could not complete the request. For more specific information, click the details button"
but when i click the details button the text box for the message is empty

After clicking OK three times the message
"An error occurred while trying to fetch data from your SharePoint site" 
is displayed.

After that the first message continues coming untill you kill SharePoint Designer from the Task manager.

Looking in ULS shows this row that could be relevant
Policy Cache object in WebApplication: <GUID> Zone: 0 possibly corrupt. It has expected size 43, actual size 39.

but searching the web for that didnt help... I only found one matching post, that didnt get an answer

After searching the web for similar errors I have tried:

  • emptying the sharepoint designer cache
  • reinstalling sharepoint designer
  • verifying SharePoint Designer is allowed in both web application and site collection
  • deleteing key Open Site in current user registry
  • trying different variations in IIS Authentication (although the one i have is used in the production environment)
  • restarting CacheCluster (App fabric)
  • Removing Alternate Access Mappings (I only have http://servername atm)

any suggestions on other things to try would be welcome.


//Sigge

Replies

Lisa Chen1226 on Tue, 22 Aug 2017 06:46:46


Hi Sigge, 

Per my research,  this issue occurs because anonymous authentication for the SharePoint web application that hosts the SharePoint site is disabled in Internet Information Services (IIS). 

The Windows Communication Foundation (WCF) runtime requires that the security settings of the WCF service match the IIS settings. When anonymous authentication is disabled in IIS, WCF cannot use anonymous binding. Therefore, the WCF runtime throws an exception if there is anonymous binding in WCF.

Web applications use a claims-based authentication method. Therefore, the identity of web application threads is forms-based instead of Windows-based.  When a Windows-based user identity is not used and WCF binding is not anonymous, the WCF runtime throws an "Access denied" error. Additionally, a 302 error code is returned to the logon page.

To resolve this issue enable anonymous authentication for the SharePoint web application in IIS.

http://support.microsoft.com/kb/2758431

Also you can try:

http://www.c-sharpcorner.com/UploadFile/anavijai/error-the-server-could-not-complete-your-request-when-tryi/

http://www.brightworksupport.com/error-when-opening-site-in-sharepoint-designer-2013/

Best Regards, 

Lisa Chen 

Sigge Persson on Tue, 22 Aug 2017 15:53:36


Thank you Lisa,

The SharePoint Site in itself has anonymous authentication turned on, but there might be a service that does not, i will investigate.

 Kind regards
//Sigge

Sigge Persson on Thu, 24 Aug 2017 07:50:26


I have found the issue.

The server did not have the windows feature -> .Net Framework feature
Http Activation 
installed

after installing it, everything worked fine.

Kevin Cole (MCM) on Wed, 06 Dec 2017 22:42:21


The policy cache error was irrelevant to your error, but was addressed here:

https://social.technet.microsoft.com/Forums/en-US/dfbf081b-7cc5-485c-97e4-aeba34f2c7f5/get-error-policy-cache-object-in-webapplication-possibly-corrupt-it-has-expected-size-47-actual?forum=SP2016

I've just added this link as google brought me here when trying to resolve my issue.