Question

VRochet on Tue, 09 Oct 2018 14:03:45


We have been trying to troubleshoot an issue for months on one of our site collection.

Three 2010 workflows, all containing a feedback or approval task process all failing randomly:

Scenario:

The individual task are always created correctly, usually between 3 and 20 tasks for each review / approval.

Some are completed without issue, then completely randomly a task assignee completes their task and the task goes to In Progress Status, all remaining uncompleted task are cancelled.

I have searched for a pattern, a common denominator for the failing tasks and could find any.

When running a script for "locked" tasks, the tasks in questions are not returned as locked.

MS Premium support advised to turn off the workflow timer job service on the application server, which we did and for EXACTLY 3 months, this issue did not occur, then exactly 90 days after we turned that service off, the issue resurfaced, first occurring at about 1% of the time, but for the past 2 days, after weeks trying to track the root cause, it's closer to 100%.

This is a fully redundant SP 2013 install.

The fact that the issue did not occur for a while 100 days after the site launch and then for another 3 months, and that the issue happens with 3 different workflows, leads me to believe that the root cause is a back end problem rather than a workflow design.

Has anyone come across this issue before.

Thanks in advance for your help.

Vee


Replies

Linda ZL on Wed, 10 Oct 2018 09:40:06


Hi,

For this complex issue, I recommend you to submit a ticket to our premier support where our engineer can remote help you directly.

It would also be appreciated if you can keep updating this thread once there any finding about it.

Best regards,

Linda Zhang