How to enable Internet access for Azure VMs?

Category: azure management

Question

Shim Kwan on Thu, 23 Jun 2016 22:51:38


Hi,

We have followed the advice in this document to enable Internet access for our Azure based VMs, but unfortunately none of our VMs can connect to the Internet. http://www.microsofttrends.com/2015/03/30/internet-access-from-azure-vm-not-working-problem-solved/

Here are screenshots of our config - please could someone assist?

Thank you,

SK

Replies

Nick Hogarth on Thu, 23 Jun 2016 23:55:47


I deployed a Server 2012 R2 from the gallery and linked it to my virtual network. I made no changes to the VM. I have no DNS servers registered in my virtual network. When I RDP into my VM Internet access works fine. Without specifying any DNS servers it uses Azure-provided name resolution by default (which is the one you manually specified 168.63.129.16)

Have you made any changes to your VM?

To confirm your DNS is working, if you open up cmd on an Azure VM, then do a "nslookup google.com" what is your response?

Are you sure you have not configured any settings on the network adapters within your Azure VM?

Shim Kwan on Fri, 24 Jun 2016 01:34:02


HI,

NSLookup doesnt resolve.

I have also included my IPConfig results below, in addition to the screenshots already provided above. And no, I have not touched any other IP related settings within the Azure VM.

The crossed out bits are my machine name, the AD domain, MAC address & IPV6 config details.

I'm assuming the 'reddog' reference is something from the Microsoft Azure DHCP server?




Nick Hogarth on Fri, 24 Jun 2016 01:44:56


It says you are trying to use 127.0.0.1 (local host) to resolve hostnames. nslookup shows this and so does your ipconfig /all. Can you double check you haven't added a DNS server on the network interface within the Azure VM?

Shim Kwan on Fri, 24 Jun 2016 01:53:07


Working with Azure VMs is like working with Windows NT4.0 all over again :)

If I change the DNS server, I have to reboot my VM, as I loose RDP connectivity....

Yes, I had 127.0.0.1 configured. I have now removed it and the issue still persists.

Nick Hogarth on Fri, 24 Jun 2016 01:56:06


I never have any issues. Can you do an ipconfig /flushdns and then do an nslookup again and see which nameserver it is using? Also you shouldn't need to set the DNS server in the virtual network in azure, as mine picked up the Azure DNS server automatically.

Shim Kwan on Fri, 24 Jun 2016 02:28:30


I have cleaned up the Azure Virtual Network configurations to the MS DNS servers. Rebooted. And the problem still persists. Screenshots below:

Nick Hogarth on Fri, 24 Jun 2016 02:41:23


and if you try and resolve a name after nslookup?

Works fine for me. I am using the same 168.63.129.16

Shim Kwan on Fri, 24 Jun 2016 02:57:50


here you go, getting a "Format error"

 

Nick Hogarth on Fri, 24 Jun 2016 03:07:44


Format error - The DNS name server found that the request packet was not in the proper format. It may indicate an error in nslookup.

is it the same issue if you try and browse the web now or does it still not resolve the hostname?

Edit: if it doesn't work, test out setting your DNS server on your virtual network to google DNS. 8.8.8.8 see if that works.


If this post was helpful, please click the up arrow or propose as answer.


Shim Kwan on Fri, 24 Jun 2016 03:34:14


Hey Nick, look at this :) Will try to reconfigure the VM DNS to 8.8.8.8 and hope this resolve this particular issue - many many thanks for your patience in helping us troubleshoot this issue!

Shim Kwan on Fri, 24 Jun 2016 03:39:05


and we have Internet access !!!

thank you Nick !!!