Unable to point the azure Stack to a time server

Category: azure stack

Question

Nirmal Johnson on Fri, 16 Mar 2018 10:13:34


Hi All ,

I am having issue while running the Script

cd C:\CloudDeployment\Setup
$adminpass = Get-Credential Administrator
$aadcred = Get-Credential "<Azure AD global administrator account name>"
.\InstallAzureStackPOC.ps1 -AdminPassword $adminpass.Password -InfraAzureDirectoryTenantAdminCredential $aadcred -TimeServer 52.168.xxx.xxx

Error :- Failure Connecting to the time server 52.168.xxx.xxx

The azure stack is behind an firewall and connects to the internet Via a proxy

Any insights ?

*****************************

Thank you I was able fix the time server issue

***********************************



Replies

AjayKumar-MSFT on Fri, 16 Mar 2018 14:25:38


Ensure that the BIOS and your local system time zone and the time is set correctly, retry the deployment and let us know how it goes.

 

Azure Stack requires access to the Internet, either directly or through a transparent proxy. Azure Stack does not support the configuration of a web proxy to enable Internet access. Both the host IP and the new IP assigned to the MAS-BGPNAT01 (by DHCP or static IP) must be able to access Internet. Ports 80 and 443 are used under the graph.windows.net and login.microsoftonline.com domains.

 

Ensure that Azure Stack deployment prerequisites are met.

 

If the issue persists, do provide the following information:

 

Build/Version:  

Get-Content "C:\CloudDeployment\Configuration\Version\version.xml"

 

Directory type: 

Azure AD or ADFS

 

Hardware: 

How many CPU Cores, RAM, Get-Disk output

 

Network: 

Static or DHCP.

  

BareMetal or Nested Hyper-V:

 

Deployment parameters used:

 

In the interim, if you haven't already done so, try redeploying using the -rerun parameter.

NOTE: Make sure you are running the deployment as under the AzureStack\AzureStackAdmin account.

 

cd C:\CloudDeployment\setup

.\InstallAzureStackPOC.ps1 -rerun

---------------------------------------------------------------------------------------------------

Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

Gary Gallanes [Boeing Digital Aviation Services] on Fri, 16 Mar 2018 16:56:45


Hello,

An Azure AD enabled deployment of the ASDK will not complete successfully from behind a proxy and is not supported

The ASDK deployment applies the -TimeServer IP to the AzS-DC01 VM and then all the other VMs and Host sync to AzS-DC01 as the TimeServer.  The TimeServer needs to be accessible to AzS-DC01in order to pass validation.

  

You can however, deploy an ADFS enabled deployment of ASDK from behind a proxy server.

I suggest setting up a NTP server on your local subnet or set the Proxy setting on AzS-DC01 so it can reach your NTP/Timeserver.

      

We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

If you experience any issues with Azure Stack or the current ASDK release, please feel free to contact us.

             

 Thanks

Nirmal Johnson on Thu, 22 Mar 2018 09:53:06


Thank you I was able to fix the time server issue

AjayKumar-MSFT on Fri, 23 Mar 2018 20:01:10


Glad to know the issue is resolved. Thanks for the update.

---------------------------------------------------------------------------------------------------

Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

Munir Tajudin on Thu, 31 May 2018 21:20:03


hello there, 

may i know how you fixed the issue ?

AjayKumar-MSFT on Thu, 07 Jun 2018 10:17:10


Are you using an Azure AD or ADFS directory type?

If feasible you may restart the AzS-DC01 VM and then check to see if that helps.