Error while trying to connect to Oracle

Category: azure data factory

Question

MHassani on Wed, 06 Jun 2018 13:22:21


Hi everybody,

I am trying to specify an Oracle Database connection but keep getting the error:

Error when processing request, ERROR [080001] [Microsoft][ODBC Oracle Wire Protocol driver][ORACLE]TNS-12505: TNS:listener could not resolve SID given in connect descriptor'Type=,Message=ERROR [08001][Microsoft][ODBC Oracle Wire Protocol driver][Oracle]TNS-12505:TNS:listener could not resolve SID given in connect descriptor,Source=,',ActivityId

Does anyone knows why I am getting this issue? and how I can solve this?

Thank you in advance!!

Replies

Fang Liu (ADMS) on Wed, 06 Jun 2018 13:49:28


Are you using service name or sid to connect oracle? Could you share the screenshot of the configuration? Or could you share the activity id in the error message?

MHassani on Wed, 06 Jun 2018 14:32:51


I have tried both sid and service name

Hereby the ActivityId: ba534ded-1394-4fc0-4515-21b9124e1cfe

Fang Liu (ADMS) on Sat, 09 Jun 2018 06:22:58


Sorry that I didn't find any log with your activity id. 

But just googled the error message. it seems you give the wrong sid? 

https://community.oracle.com/thread/405675?start=15&tstart=0

1. Seems you are using ODBC connector in ADF? Could you try Oracle connector?

2. You could also try test connection with the integration runtime diagnostics. Does it pass the test connection?


Psmak-R on Fri, 05 Oct 2018 20:02:24


Hi All!

Having the same problem. I've tried both Oracle connector and ODBC but both of them dont seem to work which is very strange because I can connect from the machine where IR is installed succesfully to Oracle Db.

Can you advise?

Regards,

PsmakR