Accessing Automation Options while creating a VM does not work

Category: azure devtest labs

Question

Andreas Fischler on Thu, 10 Jan 2019 19:17:26


Hi all,

for my current project i am trying to automate the creation of a VM in Azure DevTest Labs.

But whenever i try to access the automation options while in the create VM Blade of the DevTest Lab nothing happens.

It worked fine before christams but there seems to have been an update since then.


Replies

kobulloc-MSFT (Azure) on Fri, 11 Jan 2019 03:36:44


Are you using Formulas to create VMs in Devtest Labs?  There was a brief issue with that, but it should be fixed now.

AmanGarg-MSFT on Fri, 11 Jan 2019 05:11:13


Hi Andreas,

I tried accessing the Automation Options while creating a Ubuntu, Redhat and Windows VM and I was successfully able to do so. Is there a specific base that you are seeing this for?

You can try the below options

1. Refresh you window

2. Clear your cache

3. Try a different browser

If the problem still persists, please let us know the base(s) you are using to create your VM and we will look into it further.

Andreas Fischler on Fri, 11 Jan 2019 07:31:41


I'm not using any formulas to create my VM. The only thing i am trying to add is the WinRM Artifact, but even if i have not artifacts it doesn't work for me.

Andreas Fischler on Fri, 11 Jan 2019 07:38:11


I have tried it with Firefox, Edge and Chrome and it doesn't work either. Same on my colleagues PC in another Azure Subscription.

I'm using a custom image based on Windows 10 Pro, Version 1809

But also using the default Windows 10 Pro, Version 1809 and other Windows 10 Pro Versions doesn't do the trick.

Also if i create a VM outisde the Azure DevTest Labs it works just find and i can download the automation template.

The only thing that happens when i click the automation Link is that i get errors in my browsers console.

Andreas Fischler on Fri, 11 Jan 2019 07:46:37


And i also tried it with disabled Adblock and in other Browsers i don't even have adblock.

AmanGarg-MSFT on Fri, 11 Jan 2019 09:16:43


Hi Andreas,

I tried with Windows 10 Pro, Version 1809, added an artifact and was still able to see the ARM template.

Can you create a new DevTest Lab and try it out in that once? Meanwhile I will inquire with the Product Team and revert in case this is a known issue.

AmanGarg-MSFT on Fri, 11 Jan 2019 09:57:37


Hi Andreas,

Just got a confirmation and this seems to be a known issue. Product team is actively working on this and the fix should be available by EOD tomorrow i.e. 12th Jan, 2019.

Will keep you posted!

Andreas Fischler on Fri, 11 Jan 2019 10:05:57


It still doesn't work, here is what i have tried:

1. Create new Azure DevTest Lab in new Resourcegroup

2. Use a different Subscription

3. Use a different Account on a different Subscription

The only difference i can see from your images is the path shown at the top when creating the VM.

For me it is:

Home > DevTest Labs > NameOfDevTestLab > Choose a base > Create lab resource

On your image i can't see anything about DevTest Labs. How did you access the creation Blade?

Andreas Fischler on Fri, 11 Jan 2019 10:08:17


Thank you so much for this information! You are a lifesaver!

And thank you all for the quick responses!

I'm looking forward to hear from you.

AmanGarg-MSFT on Sat, 12 Jan 2019 05:09:59


Hi Andreas,

The fix for the automation link is available now. Please check and let us know if you are still facing any issues.

Thanks!

Andreas Fischler on Sat, 12 Jan 2019 09:37:49


I just tried it and it works.

Thanks again for the great support!