Upload to sharepoint fails

Category: sql server powerpivotsp

Question

kman626 on Thu, 03 Dec 2009 00:48:00


I have just completed installation of powerpivot for sharepoint.  the sharepoint server is running and per the installation instructioins, seems valid.  When I attempt to save a document to the sharepoint powerpivot gallery, the upload fails.  The error message says "Your changes were saved but could not be uploaded because of an error."  When I go to the sharepoint site there is a big red X on the document and an error related to a snapshot problem. 

How do I troubleshoot what the error is from the client side or is this a server problem?


Update.

I tried to upload the file from teh sharepoint site and got this error. 

Error

The specified file is larger than the maximum supported file size.

 

Troubleshoot issues with Microsoft SharePoint Foundation.

Correlation ID: efdd4642-219f-48f6-8bba-767054c03fe3

Date and Time: 12/2/2009 4:52:50 PM

Replies

Mariano Teixeira Neto [MSFT] on Thu, 03 Dec 2009 00:59:26




Probably your workbook is bigger than 50MB, which is the default maximum upload size for SharePoint. You can, though, increase it up to 2GB.

 

To increase Web Application limits:

  1. Go to SharePoint Central Administration > Application Management > Manage Web Applications.
  2. Select SharePoint-80 and then select Resource Throttling.
  3. Change the Maximum Upload Size setting to the MB limit you want to set. (The maximum allowed by SharePoint is 2047MB.)

     

    To increase Excel Services limits:

    a.       Navigate to SharePoint Central Administration > Application Management > Manage Service Applications.

    b.      Select your Excel Service Application.

    c.       On the Ribbon, click Manage.

    d.      Click Trusted File Locations and on the following page, select your trusted location. (Typically, this is listed as http:// in the Address column.)

    e.      In the Workbook Properties area, set the Maximum Workbook Size property to 2000 and the Maximum Chart or Image Size to 100 MB.


    Hope that helps,
    Mariano

kman626 on Thu, 03 Dec 2009 01:16:18


I will bet that is is because I just sucessfully uploaded a small worksheet.

Thanks!

Elton Romero on Sat, 26 Jun 2010 13:33:39




Probably your workbook is bigger than 50MB, which is the default maximum upload size for SharePoint. You can, though, increase it up to 2GB.

 

To increase Web Application limits:

  1. Go to SharePoint Central Administration > Application Management > Manage Web Applications.
  2. Select SharePoint-80 and then select Resource Throttling.
  3. Change the Maximum Upload Size setting to the MB limit you want to set. (The maximum allowed by SharePoint is 2047MB.)

     

    To increase Excel Services limits:

    a.       Navigate to SharePoint Central Administration > Application Management > Manage Service Applications.

    b.      Select your Excel Service Application.

    c.       On the Ribbon, click Manage.

    d.      Click Trusted File Locations and on the following page, select your trusted location. (Typically, this is listed as http:// in the Address column.)

    e.      In the Workbook Properties area, set the Maximum Workbook Size property to 2000 and the Maximum Chart or Image Size to 100 MB.


    Hope that helps,
    Mariano


Yep, my problem has been fixed with changing the the Maximum Upload Size setting. Thanks a lot.

SP_VENKY on Thu, 02 Dec 2010 03:40:16


Small correction from

To increase Web Application limits:

  1. Go to SharePoint Central Administration > Application Management > Manage Web Applications.
  2. Select SharePoint-80 and then select General Settings 
  3. Change the Maximum Upload Size setting to the MB limit you want to set. (The maximum allowed by SharePoint is 2047MB.)

Regards,

Venky

Rockie_ on Thu, 14 Mar 2013 09:20:41


>>Small correction from

>> select General Settings

Right.