Question

christopherFromQS on Tue, 01 Apr 2014 11:24:18


Hi,

I have an appx package for a Windows 8.0 App, which is available via my windows intune store.

My application needs exactly following dependecy (e. g. on first install) Microsoft.VCLibs.110.00_11.0.50727.1_x86__8wekyb3d8bbwe.appx

How can I add this dependency to my appx-package correctly?

Without this dependency the installation process of the app fails!

I tried to generate an appx-bundle, but this did not work, I got the message "[...] is not valid in the bundle, because it is a framework package". I did not found any solution in intunes for (re)solving this depdency (bug), too.

Why does it not happen automatically, like in the Windows Store?
How can I add this dependency correclty to the package?


Sponsored



Replies

christoph84GE on Tue, 08 Apr 2014 07:14:10


Dear MS Team,

I have the same problem over here. We need a solution for this as fast as possible for our business application in intunes.

Best regards,

Christoph

Jonathan S - MSFT on Wed, 21 May 2014 17:30:54


Hello,

If you have not already, I would definitely suggest that you review the Support for Microsoft Windows Intune page. This forum is more for Windows Store App Submission and related developer issues. Thanks for the post!

-Jonathan

MightTrust on Wed, 23 Dec 2015 14:48:10


Dear Jonathan,

It's not only Intune question. I have the same problem with my appx package when I'm trying to install it to any device as unpublished application. How can I include all the dependencies appx packages into my appx package?

Best regards,

Alexey