Question

Creating ADFS database for with FSconfig.exe fails on Mon, 05 Aug 2013 07:34:49


I'm building ADFS in Azure. My plan is to use the Azure SQL. The problem is that FSconfig seams not to work with Azure SQL. Here's what i did untill now:
 
- I followed the documentation and created a new login and user (adfslogin, adfsuser) in a new
"adfsv21" database. Then i added the user to db_owner role.

- From c:\windows\adfs i run FSconfig: FSConfig.exe CreateSQLFarm /ServiceAccount mysa /ServiceAccountPassword ******** /SQLConnectionString "database=Adfsv21;server=[azureServer];User Id=mysa;Password=********" /AutoCertRolloverEnabled. I tried it with both accounts, mysa and adfsuser with the same poor results. The result is: "The following error occurred: The specified service account mysa is not valid.  Specify
a different service account, and try again."

- I configured odbc and tested the connection. mysa can connect but adfsuser caanot. Why?

To be short, its not working. See this post with similar problems: google to "SQL server farm configuration error"...
So, is Azure SQL & ADFS not complatible? Really not?

Sponsored



Replies

Guy Haycock [MSFT] on Thu, 22 May 2014 18:10:29


My apologies for take a super long time to reply.  Are you still having issues here?  How can we help?

Thanks Guy

Simon Gurevich - MSFT on Fri, 23 May 2014 04:09:17


Seems like the original poster is trying to use Azure SQL DB as a backend for ADFS and this is not supported