Question

dumbledad on Mon, 28 Jul 2014 16:28:33


I have a new Azure VM (the Visual Studio Professional 14 CTP 2 Windows Server 2012 R2 image) and I'm trying to install SQL Server on it. The installation fails because it cannot see the .NET Framework 3.5 installed. There are two ways I know of to fix this, one is to run

DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:"D:\sxs"

from an elevated command prompt and one is to enable the feature in the Add Roles and Features Wizard.

In each case I need the location of the source files. I think this would usually be on one's installation disk but since I'm on an Azure VM there is no installation disk. What should I use as the source path? How do I enable the .NET Framework 3.5 on an Azure VM created from a Windows Server 2012 R2 image?

Replies

dumbledad on Mon, 28 Jul 2014 16:52:59


Fixed - ignore the warnings asking for a source location and just click "install"!

Vivian_Wang on Tue, 29 Jul 2014 02:23:00


Hi,

Glad the issue was solved.

More information:

To install Microsoft .NET Framework 3.5 on Windows Server 2012

  1. Establish a Remote Desktop Connection to the Windows Azure virtual machine.

    From the Windows Azure Management Portal, under Virtual Machines, choose the virtual machine from the list, and then choose Connect.

  2. Run Windows PowerShell as an Administrator.

       At the command prompt, type the following command and press Enter.

       Add-WindowsFeature NET-Framework-Core

Regards.

Pablo Eduardo on Fri, 12 Sep 2014 14:07:54


Not work for me.

Triangle101 on Wed, 24 Sep 2014 03:08:17


Neither of these solutions works for me. Keep getting the same answer everywhere and it doesn't work. Neither the Powershell option or the regular option described above. 

PS C:\Users\solanna> Add-WindowsFeature NET-Framework-Core
Add-WindowsFeature : The request to add or remove features on the specified server failed.
Installation of one or more roles, role services, or features failed.
The source files could not be downloaded.
Use the "source" option to specify the location of the files that are required to restore the feature. For more
information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077. Error: 0x800f0906
At line:1 char:1
+ Add-WindowsFeature NET-Framework-Core
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeatur
    Exception
    + FullyQualifiedErrorId : DISMAPI_Error__Cbs_Download_Failure,Microsoft.Windows.ServerManager.Commands.AddWindo
   eatureCommand

Success Restart Needed Exit Code      Feature Result
------- -------------- ---------      --------------
False   No             Failed         {}

SPgreygoogames on Wed, 08 Oct 2014 00:12:05


As above I also still get this error. I opened a new question about my specific use case but it should apply to all trying to do this. Cannot get .NET 3.5 to install with any of the suggestions above.

afailor on Fri, 31 Jul 2015 17:50:02


This worked for me!

Thanks

Rajasekhar Veernapu on Thu, 03 Aug 2017 10:58:34


Did this works for you? I tried on Windows Server 2016 but it is failing

I tried with DISM as well and no luck

Did it solved for you??

Monika chaudhary on Mon, 07 Aug 2017 09:31:41


For specialized assistance, you may create separate forum thread here:

https://social.msdn.microsoft.com/Forums/azure/en-US/home?forum=WAVirtualMachinesforWindows

---------------------------------------------------------------------------------------------------

Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community member


UpYourGame on Tue, 31 Oct 2017 16:16:23


Using DISM did not work for me. Neither did just ignoring the alternative path warning.

 I get the following output:



Deployment Image Servicing and Management tool Version: 6.3.9600.17031 Image Version: 6.3.9600.17031 Enabling feature(s) [===========================66.2%====== ] Error: 0x800f081f The source files could not be found. Use the "Source" option to specify the location of the files that are required t o restore the feature. For more information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077. The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

I think I it is pretty ridiculous that it is THIS hard to enable features (that IMO should be enabled by default - .net 3.5). Did MS not contemplate that users might want/need to enabled features on VMs in azure?


binarytwo on Sat, 24 Feb 2018 15:50:37


After trying every suggestion I found on the web, I finally figured out a solution that worked for me.

A simple GPO will do the trick.
To verify in your scenario, run gpedit.msc & then browse to:
Local Computer Policy>Computer Configuration>Administrative Templates>System>

Find the setting titled: Specify settings for optional component installation and component repair

Enable the setting & check the box to "Contact Windows Update directly to download repair content in stead of Windows Server  Update Services (WUSUS)

I tried this once & it didn't work, but after changing the setting & a quick reboot, I FINALLY was able to implement my features.