TFS services are not available from MTM

Category: visual studio mtm

Question

Kudrik on Wed, 14 May 2014 11:51:23


I use tfs 2013 server on server. When i am trying to connect to it from microsoft test manager(MTM) on the same server it works fine. When i am trying to connect from MTM on another machine it cant connect to tfs with error tf400324 TFS services are not available: time out. In that time Visual Studio 2013 ultimate works fine with tfs on that machine and connects to tfs. Cant understand, where should i look any answers!? Please, help!

Best regards, Konstantin


Replies

Starian chen on Thu, 15 May 2014 02:32:25


Hi Kudrik,

For that issue, it may the cache issue. Please clear the TFS cache and try again.

Delete the cache folder which path like C:\Users\your name\AppData\Local\Microsoft\Team Foundation\5.0.

Thanks

Best Regards

Kudrik on Thu, 15 May 2014 08:16:14


Hi!

Thank you for you answer.

Unfortunately, it doesn't help me. Any other suggestions?

Best regards, Konstantin

Starian chen on Thu, 15 May 2014 09:52:51


Hi Kudrik,

Do you use the MTM 2013 that contain in that VS2013 Ultimate?

Do you have MTM2012, if so, please check whether it can connect to TFS.

On the other hand, please try to repair the VS and try agin.

Thanks

Best Regards

We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
Click HERE to participate the survey.


Kudrik on Thu, 15 May 2014 11:39:53


Hi!

Thank you for you answer.

I think there is a misunderstanding. I have 3 machines.

1 - Physical server with tfs 2013 installed and vs 2013 ultimate(with mtm 2013) installed. There mtm works fine.

2 - My client physical machine with windows 7 and vs 2013 ultimate (with mtm 2013) installed. There MTM doesn't work with tfs, but Visual Studio works finewith tfs.

3 - Virtual machine for testing  with windows 7 and vs 2013 ultimate (with mtm 2013) installed. There MTM doesn't work with tfs, but Visual Studio works finewith tfs.

Repair doesn't help.

Best regards, Konstantin

Vicky Song on Fri, 16 May 2014 02:21:30


Hi Konstantin,

When you add the Team Foundation Server in MTM, please try to use the IP address, it should work.

Thanks. 

Kudrik on Fri, 16 May 2014 06:43:04


Hi Vicky!

Thanks for your answer!

But again, it doesn't help! I dont know what to do already...really. so strange.

Best regards, Konstantin

Vicky Song on Tue, 20 May 2014 08:24:36


Hi Konstantin,

You get a very strange issue to me. As you can connect to the TFS server in VS, you actually has nothing wrong with your user account, nor network connection, nor TFS server, nor firewall settings. Seems all are right.

How about you perform a clean reboot of your client machine then try again?

Thanks.