AZURE BAAS - Blockchain Ethereum Proof Of Work - Mining node stopped working

Category: azure blockchain

Question

Babaso on Tue, 29 May 2018 22:01:44


We have Blockchain Ethereum Proof Of Work instance with 6 mining node and 2 transaction nodes. Initially, it works fine for few transactions after that it does not. If we restart the nodes it works again for few transactions. Now 2 mining nodes are stopped. working please check attached screenshot.

The message which we get some time is transaction is not mined in default time. It may be still in the mining process. It never executes. This is with default Genesis block with option Custom Genesis Block = NO.

We also tried creating with Custom Genesis Block, It does create with Low Difficulty but default account is not unlocked though we pass actual/correct passphrase. Then we created another account and unlocked it and transferred Ether from Main Default account. The issue with this is Ether balance get drastically reduced to 0 and when you transfer Ether to newly created account It shows received Ether and in few seconds it becomes 0. When we do newly account as EtherBase account then also it doesn't work it showed mined few Ethers and in few seconds it again becomes 0.

We tried with both the approach having Custom Genesis Block and with Default also.

When I connect to Rinkeby Test Network everything works without any issue.

Thanks


Replies

Microsoft Azure Blockchain Team on Wed, 30 May 2018 17:05:03


Hi,

Regarding miner nodes stopped, the screenshot you mentioned is not found in your post. Are the problematic miner nodes able to peer with others?

Regarding prefund account, it is unlocked for IPC only during deployment time. So it cannot be used as an unlocked account through RPC endpoint.

Regarding ether disappearance, it is observed that bots on internet exists that scanning port 8545 for either transfer transactions and transfer ether when receiving account is unlocked. Although the ether here is valueless, having unlocked account for RPC is not recommended.

Thanks.