Question

etang on Thu, 01 Mar 2018 16:33:27


This in reference to the Stream Analytics/Machine Learning tutorial.

https://docs.microsoft.com/en-us/azure/stream-analytics/stream-analytics-machine-learning-integration-tutorial

I'm having difficulties getting the final sentiment scores to show up in the output with the slightly newer Azure Portal layout. Even when i'm running my Stream Analytics job I'm not getting any inputs so likely the CSV file is not coming in correctly from the Blog storage after its been uploaded there. Also the name of the file in the documentation doesn't match that of the file in GitHub "sampleinput.csv".  I'm thinking the fields in the SQL may be incorrect to pull from the CSV in the Blob file, any suggestions would be appreciated.

Thanks,
Eric

Replies

Sneha Gunda[MSFT] on Fri, 02 Mar 2018 01:47:49


Hi Eric,

I work in the Stream Analytics documentation team, I tested the scenario and it works fine. I see that the ASA job created a new output file in the blob. you should use the samplinput.csv(https://github.com/Azure/azure-stream-analytics/blob/master/Sample%20Data/sampleinput.csv ) file hosted in GitHub, though the name is different in the screenshot. The query is valid too. Make sure that you have used correct values for the Web service URI and the API Key. You can test the job with the sample data to see that there aren't any issues. 

I agree that the portal screens are outdated, I submitted an update to fix the screens. The changes will be live tomorrow.