Question

Nandan1984 on Tue, 05 Sep 2017 12:57:14


I tried creating Azure VM's using Template as suggested in following article's however getting error while deployment.

Moreover if this shouldn't work than please advise do we have any predefined templates which we can use to create VM's for Lab testing.

Below are the articles which I followed.

https://azure.microsoft.com/en-in/resources/templates/active-directory-new-domain-ha-2-dc/

https://azure.microsoft.com/en-in/resources/templates/active-directory-new-domain

Replies

SumanthBM on Tue, 05 Sep 2017 13:38:02


Suggest you to elaborate on the environment/lab that you are trying to deploy

Refer here for general Azure Quickstart Templates, Also you can refer to the GitHub link for various example templates

------------------------------------------------------------------------------------------

Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

Nandan1984 on Tue, 05 Sep 2017 15:27:37


Hello Team,

I followed the same https://azure.microsoft.com/en-in/resources/templates/ link you provided and I picked one the the template and followed all the instructions however that didn't worked and got the error message.

Also I again tried another template for ADFS Lab following the below link.

https://github.com/paulomarquesc/adfs-6vms-regular-template-based

now the Deployment was successful however unable to connect to the VM's as the Connect option is showing greyed out.

Regards,

Nandan

SumanthBM on Tue, 05 Sep 2017 17:18:48


Refer to the article Azure RM VM Connect Button Greyed Out

If the Connect button for your VM is grayed out in the portal and you are not connected to Azure via an Express Route or Site-to-Site VPN connection, you need to create and assign your VM a public IP address before you can use RDP. You can read more about public IP addresses in Azure.

For more information, refer here

------------------------------------------------------------------------------------------

Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

Nandan1984 on Thu, 07 Sep 2017 12:16:32


Thanks for the help,

I enabled the Public IP as dynamic and after that I can see the connect option now.

SumanthBM on Thu, 07 Sep 2017 12:28:03


Glad to hear that issue got fixed.

------------------------------------------------------------------------------------------
Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.