Unable to make web server accessible publicly

Category: azure vm

Question

Chris Day Microsoft (MSFT CSG) on Mon, 11 Jan 2016 00:51:14


From Sherman Chen

@theprognerd via Twitter

"Using the new #azure #UI to create WinServer #VM. Can't figure out how to make web server accessible publicly.

@AzureSupport Hi, I have set up the Inbound Rules to allow the endpoint for port 80. Still no luck. pic.twitter.com/ebyp5kQnP9"

http://twitter.com/theprognerd/status/685740900580864000

Thanks,

@AzureSupport

Replies

Marcus Robinson (Technical Evangelist, Microsoft) on Mon, 11 Jan 2016 15:03:49


The rules you have created look good. Is windows firewall within the VM definitely allowing traffic in on the required ports?

Are you accessing using <a href="http:///">http://<serveripaddress>/ ?

Marcus

Siva Edupuganti on Tue, 12 Jan 2016 00:32:16


It worked for me with this inbound rule. Make sure to check the windows firewall configuration to allow port 80. 

Note that when a VM is created from the portal (in ARM model), it gets automatically associated to a virtual network (vnet), a specific subnet within the vnet and a network security group.

When creating the inbound security rule, make sure to:


ShermanCWZ on Wed, 13 Jan 2016 15:45:14


Yes, I finally got it to work! Realized 2 things I have learnt from this experience. One is that I should not install the Windows Server Essentials from the Turn on feature functionality.

Second, I need to set the source port range for inbound rule to "*".

And now I have a wonderfully working Web Server. Now I can start setting up all the technology specific infrastructure.