Question

LockAS on Wed, 02 Dec 2015 10:22:41


Hi

We're trying to run a hostd build but it errors out with the following:

2015-12-02T10:13:01.8813130Z        "C:\a\1\s\MAIN\mysite_co_uk_57_.metaproj" (default target) (2) ->
2015-12-02T10:13:01.8969395Z        (Build target) ->
2015-12-02T10:13:01.8969395Z          C:\a\1\s\MAIN\mysite_co_uk_57_.metaproj : error MSB6006: "aspnet_compiler.exe" exited with code 1.
2015-12-02T10:13:01.8969395Z     3 Warning(s)
2015-12-02T10:13:01.8969395Z     1 Error(s)
2015-12-02T10:13:01.8969395Z Time Elapsed 00:24:37.35
2015-12-02T10:13:02.3032142Z ##[error]Unexpected exit code received from msbuild.exe: 1
2015-12-02T10:13:02.3500656Z Finishing task: VSBuild
2015-12-02T10:13:02.4438400Z Starting task: Publish Artifact: drop
2015-12-02T10:13:02.4438400Z ##[error]Powershell V3 or above is not installed, current PowerShell Version is 0.0
2015-12-02T10:13:02.4438400Z Finishing task: CopyPublishBuildArtifacts
2015-12-02T10:13:02.4438400Z ##[error]Task VSBuild failed. This caused the job to fail. Look at the logs for the task for more details.

The logs on't show any more information than the above.

Has anyone else encountered this error in a hosted build, I can't see what would required PS V3 to build or how to include it in the hosted build proces.

Thanks
Adam


Sponsored



Replies

Asha99 on Thu, 03 Dec 2015 06:36:37


Hi,

Thank you for reaching out to us. I am currently researching to gather more information with regards to your request. I shall revert back to you with an update at the earliest. Sincerely appreciate your patience.

Regards,

Asha

Asha99 on Tue, 08 Dec 2015 04:10:43


Hi Adam,

Greetings!

Has this issue gone away since?

There was a temporary issue with some of the hosted images last week.

I would request you to share your account name here:v hyphen ashas at Microsoft dot com,it will help us to answer your query better.

Regards,

Asha

keithn77 on Mon, 14 Dec 2015 09:11:01


Hi Asha,

I am having the exact same issue with the Visual Studio Online build servers,  do you have any idea what is going on?

Thanks,

Keith

Asha99 on Tue, 15 Dec 2015 07:58:29


Hi,

Greetings!

I would request you to send your Account name (ex:myaccountname.visualstudio.com) .so that it will help us to answer your query better.

Regards,

Asha

H_Hilal on Fri, 05 Feb 2016 09:36:46


Hi Asha,

I was using VSTS build with no problems. Recently, I received the following error at the step of Publish Artifact: drop. FYI, we use the hosted agent of VSTS. Do you have any suggestions?

2016-02-04T13:32:40.5059870Z ##[error]Powershell V3 or above is not installed, current PowerShell Version is 0.0

I can provide you the account name in a private message, please provide me your e-mail address.

Thanks.

HH