Question

Ruben Glez on Thu, 14 Feb 2019 21:05:55


Farm Software: Microsoft SharePoint Server 2013 Enterprise, Microsoft SQL Server 2012 SP1 Standard, Microsoft Windows Server 2012 R2 Standard
Farm Architecture: 1 WFE server, 1 DB Server
Last patches: KB4092472, KB3203396, KB3203394, KB3203395, KB3213558, KB4461591, KB3203401.
A few days ago, our Production server was patched, and the search service get stuck and started showing the next message:

The search service is not able to connect to the machine that hosts the administration component. Verify that the administration component ‘XXX-XXX-XXX-XXX’ in search application ‘Search Service Application’ is in a good state and try again.


Trying to repair the search service I reset the IIS using the command line (iisreset).
A few minutes after I ran “iisreset” I went to one of my sites and I get errors on the top/left navigation bars. 

and after a few minutes the server started to have a weird behavior, it didn’t recognize my permissions as Farm Admin/Site Collection Admin and I wasn’t able to see anything, I was prompt with the Access denied page. I tested the same for other test accounts and it happened the same.
Trying to troubleshoot the problem I went to the Central Administration and found the Claims to Windows Token Service and the Distribution Cache service were stopped. I went to confirm this in the Windows Services OS tool and in effect, the Claims was stopped but the AppFabric (Distributed Cache) was not. Actually, it says that is Running. I went again to the Central Administration to start both and I just could start the Windows Token Service, I cannot start the Distribution Cache service in the CA even though the AppFabric is running, I don’t get any error, but it simply doesn’t start.

Does anyone have any idea what’s going on with my farm? Do you guys think the permissions issue I got is related to the Distributed Cache service I cannot run from CA? Do you know how can I started the Distributed Cache service from CA? I really appreciate your thoughts (I will add the images below)

     

Replies

Grace WR on Fri, 15 Feb 2019 06:18:57


Hi Ruben,

Try to use PowerShell command to start the Distribution Cache service and check if it is running, run the SharePoint 2013 Management Shell as administrator and execute the command below:

$instanceName ="SPDistributedCacheService Name=AppFabricCachingService"

$serviceInstance = Get-SPServiceInstance | ? {($_.service.tostring()) -eq $instanceName -and ($_.server.name) -eq $env:computername}

$serviceInstance.Provision()

If the issue still exists, try to execute the command below to remove and re-add the service and check again:

Stop-SPDistributedCacheServiceInstance -Graceful

Remove-SPDistributedCacheServiceInstance

Add-SPDistributedCacheServiceInstance

If the same, run the command below:

PSConfig.exe -cmd upgrade -inplace b2b -wait -cmd applicationcontent -install -cmd installfeatures -cmd secureresources -cmd services -install

Best regards,

Grace Wang

Ruben Glez on Fri, 15 Feb 2019 14:47:07


Hi Grace,

Thanks for your quick response. What worries me a little bit is that I found this information about the use of $.

-https://docs.microsoft.com/en-us/sharepoint/administration/manage-the-distributed-cache-service

 Important

Do not use service account names that contain the symbol $.

And this one:

-https://social.technet.microsoft.com/Forums/lync/en-US/b4014e09-853f-4943-9d1e-c77dd3cee7d1/-in-service-accounts?forum=sharepointadmin

I want to be very careful because this is our Production environment and I don't want to end up in a nonfunctioning or unrecoverable state. I know about the importance of using the "Distributed Cache" carefully.

Could you please confirm that nothing wrong will happen using $ ? In case affirmative, should I run the Powershell commands using the Farm Setup account?

Thanks for your support.

Grace WR on Mon, 18 Feb 2019 07:17:50


Hi Ruben,

Do you mean you worry about the $ in the command I provided above?

The $ in the command is not used in service account names, it’s a variable for storing data which can be used later in the script.

And we need to run the command as SharePoint Farm Administrators.

Best regards,

Grace Wang

Ruben Glez on Fri, 22 Feb 2019 17:11:56


Hi Grace,

Thanks that works!... :)