Having Trouble with OLAP Processing Dimension Progress

Category: sql server analysisservices

Question

Onur Gürkan Gültekin on Sun, 15 May 2016 12:28:41


I have created a dimension named "PRODUCT". I have used "ID" for key columns and "NAME" for name name columns.

Product Dimension

After that i have clicked Process button and it has been successfully deployed but when i have clicked the "run" button then i got error like this. Could anyone help this? I am new to OLAP analysis serives.



Error Details:

<Batch xmlns="http://schemas.microsoft.com/analysisservices/2003/engine">
  <Parallel>
    <Process xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:ddl300="http://schemas.microsoft.com/analysisservices/2011/engine/300" xmlns:ddl300_300="http://schemas.microsoft.com/analysisservices/2011/engine/300/300" xmlns:ddl400="http://schemas.microsoft.com/analysisservices/2012/engine/400" xmlns:ddl400_400="http://schemas.microsoft.com/analysisservices/2012/engine/400/400">
      <Object>
        <DatabaseID>ONU_GUL</DatabaseID>
        <DimensionID>PRODUCT</DimensionID>
      </Object>
      <Type>ProcessFull</Type>
      <WriteBackTableCreation>UseExisting</WriteBackTableCreation>
    </Process>
  </Parallel>
</Batch>
Processing Dimension 'PRODUCT' completed.
Start time: 5/15/2016 3:17:14 PM; End time: 5/15/2016 3:17:14 PM; Duration: 0:00:00
Processing Dimension Attribute 'ID' completed.
Start time: 5/15/2016 3:17:14 PM; End time: 5/15/2016 3:17:14 PM; Duration: 0:00:00
Errors and Warnings from Response
Internal error: The operation terminated unsuccessfully.
Server: The current operation was cancelled because another operation in the transaction failed.
The datasource, 'ONU GUL', contains an ImpersonationMode that is not supported for processing operations.
Errors in the high-level relational engine. A connection could not be made to the data source with the DataSourceID of 'ONU GUL', Name of 'ONU GUL'.
Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'PRODUCT', Name of 'PRODUCT' was being processed.
Errors in the OLAP storage engine: An error occurred while the 'ID' attribute of the 'PRODUCT' dimension from the 'ONU_GUL' database was being processed.

Replies

David Harazi on Sun, 15 May 2016 12:39:41


Hi ,

It points on the data source ability to create connection and process the data .

Can you connect to the data source ? Double click on 'data sources' -> Edit -> Test connection .

Onur Gürkan Gültekin on Sun, 15 May 2016 13:05:25


Yes it is about data source accessibility but when i have a test my connection it was successfull with same settings.

test ok

Solution of my problem:

After that i have changed my data source impersonation information to use a specific windows user with the same credentials from use the credentials of the current user, the problem has been solved interestingly enough :)