Question

Developer_Cory on Fri, 19 Feb 2016 15:25:25


I needed to reconfigure a catalog connection to a subsite Pages library, so I disconnected it.  I manually cleaned up the navigational term set and allowed a full crawl to complete.  When I attempted to reconnect the catalog, the connection was no longer available.  After doing some online searching I found this article (see below) mentioning that if a custom result source is set as default it will prevent connections from displaying.  I had a custom site collection result source set as the default.  I changed that back to Local SharePoint Results, ran another full crawl and incremental crawl and catalog still not showing.

What is strange is, after disabling the list as a catalog, re setting the index, then re-enable the list and doing a full and incremental crawl I can see the catalog connection at the subsite level, but not at the site collection/root level.  Also, on the publishing farm I can see the connection at the site collection level.

Another thing to note is that on the authoring farm at the root level I can see another connected connection on the Manage Catalog Connection screen, but when I click "Connect to catalog" it disappears.  In the subsite and the publishing farm, this connection displays on both screens.  So it seems at the root level of the authoring farm something is preventing ALL connections from displaying after the disconnection.

article link: http://sadomovalex.blogspot.com/2013/11/problem-with-missing-catalog.html

Any help?

Thanks,

Cory


Replies

Wendy DZ on Mon, 22 Feb 2016 03:07:54


Hi Cory,

Where did you change the custom result source to Local SharePoint Results? In SharePoint Central Administration or just the subsite?

Please go to the top site of the problematic site collection, and go to Site settings->Result Sources, make sure Local SharePoint Results is set as default. Then do a full crawl.

If the above doesn't work, please go to ULS log, check if there is more information about this issue.

In SharePoint 2013, the default path of ULS log is: C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\LOGS.

Best Regards,

Wendy

Developer_Cory on Mon, 22 Feb 2016 16:48:21


Wendy,

There was a custom result source set at the top level (Site Collection) set as default, which I reset to be Local SharePoint results.  After doing that I did several full and incremental crawls as well as an index reset and full crawl. Still not seeing the catalog at the Site Collection level.

Another item to note is the application is consuming a published Search service hosted on another farm.  In the application ULS I can see the entry and exit points for /_layouts/15/AddCatalogSource.aspx, with no errors in between.  In the Search ULS there are no references to the AddCatalogSource page, is there something similar I can search for to find the catalog creation attempt?

Cory

Wendy DZ on Tue, 23 Feb 2016 01:26:35


Hi Cory,

Please try to clear the config cache, and do an IISRESET.

After that, test again, compare the  result.

About clearing config cache, you can refer to:

http://spcachecleaner.codeplex.com/

Best Regards,

Wendy

Developer_Cory on Thu, 25 Feb 2016 15:44:07


Wendy,

We performed the steps listed on the Search farm and still no catalogs appear at the root site level.  I also checked the Application ULS, and no exception errors listed.

Anything else?

Thanks,

Cory