Question

h_chin on Wed, 15 Sep 2010 06:48:51


Hello,

Has anyone come across this before?

I have a basic document library for which I have enabled "Allow management of content types" and disabled "Launch forms in a dialog".  Both of these settings are in the "Advanced Settings" page.  Also, the document library does not have versioning enabled and check out is not required.

I added the OOTB "Document Set" content type to this document library and allowed OOTB "Document" content type documents in this document set.  This document set does not have any default content.

The issue arises after I upload multiple files and click the "Done" button.  After I do this, the browser redirects to the top level of the site!  For example, if I uploaded to my document set at http://server/sites/anyname/doclib, I am redirected to http://server/.

This issue has come up in both a standard server and an enterprise server.

Steps to repeat issue:

  1. Create a document set
  2. Open the document set
  3. Select "Upload Multiple Documents"
  4. Drag and drop or browse for files
  5. Click "OK"
  6. Click "Done"

Actually, this issue also occurs when "Launch forms in a dialog" is enabled.  In this case, you just have to navigate to the upload form directly (with all the necessary query string parameters, of course).

Has anyone else seen this issue?  Does anyone know of a workaround without having "Launch forms in a dialog" enabled?

Any help would be appreciated.

Regards,

Harry


Sponsored



Replies

Fred El - MSFT on Sun, 26 Sep 2010 15:23:44


We couldn't reproduce this problem.  Might be something else contributing to this problem in your environment or setup. Since this will take some digging you could open a support case to try to get to the bottom of this oddity.

If you don't find the answer you need in the forums, and you'd like additional help, please feel free to visit the link below and see if any paid support option available may suit your needs:
http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

In the meantime feel free to continue seeking advice here. Other members of the community may have encountered the issue you're seeing, and have a solution to offer.

saffron4 on Wed, 13 Jun 2012 19:57:01


Hi,

We are facing exact same issue as described above. 

Have you solved this problem yet? Any workarounds?

Thanks!

Chuck LaForte on Mon, 26 Nov 2012 16:48:27


Hi Harry,

I get this behavior too, when I disable the form dialog setting as you described.

I've seen this in three different Farms for different clients, so I'm venturing that this is a bug and not related to your content type or version settings.

-Chuck