HTML Client jquery-mobile 1.4

Category: visual studio lightswitch

Question

J.Nord on Wed, 08 Jan 2014 09:33:15


Is it possible to use jquery-mobile 1.4 in lightswitch 2013?

Regards

j.nord

Replies

Justin Anderson on Wed, 08 Jan 2014 10:17:16


The client runtime for HTML clients requires the use of jquery.mobile version greater than or equal to 1.3 and less than 1.4 as specified by the NuGet package manager. Using version 1.4 is not supported.

novascape on Sun, 30 Mar 2014 00:24:51


jQuery Mobile 1.4 has now been out for more than 3 months. When jQuery Mobile version 1.3 came out it wasn't long before it was supported in LS.

When can we expect support for jQuery Mobile 1.4?

Thanks in advance

mrrobs on Thu, 17 Jul 2014 19:44:27


Any news on JQuery Mobile 1.4 and JQuery 2 support in LightSwitch?

It would be good to know. There are some fixes to bugs in JQuery 2 that cause us some problems using JQuery 1.9.1 which we currently are finding tricky to work around.

One 1.9.1 bug that is bothersome but not fatal is the events on getScript don't fire correctly so the call never fails even if it can't fetch the script. Fixed in JQuery 2

thanks...

LittleBobbyTables on Fri, 18 Jul 2014 00:00:04


jQuery 2.0+ works with LightSwitch HTML without any problems.