Problem getting logs from Azure VM at Log Analytics

Category: azure operational insights

Question

Jun Bin on Fri, 26 Apr 2019 01:42:21


Hi,

I had connected my Azure VM into my Azure Log Analytics Workspace.

But Log Analytics is not getting any logs from that particular Azure VM.

May I know what is the problem? I had checked that the Azure VM have internet connection.

Regards.

Jun

Replies

Femisulu on Sat, 27 Apr 2019 02:09:59


Hi Jun, A few questions...Is this a linux or Windows VM? Is the VM on-premise or in Azure? Has this configuration ever worked in the past? Do you have additional VMs you can test with?

In my experience, there is usually a time lag between when the VM log data is configured and when the data appears in the workspace.

Also sharing this reference that may be useful for you to troubleshoot this issue.

Just in case you haven't seen these, below are additional references on connecting VM log data to Log Analytics workspace

1. Azure VM

2. On prem VM

Hope this helps.

Cheers.

Anand Rao on Tue, 30 Apr 2019 07:59:05


Hello Jun , 

Once the agent is installed on the VM, you need to configure the data logs , so that specific data can be imported from the VM, instead of importing all events. 

Here is how you do it : 

Navigate to Azure Analytics workspace -> Under Connect a data source -> click Windows, Linux and other sources -> then DATA -> then select the kind of data you want to analyze in log Analytics. 

You should see the data fairly qucikly in log analytics. Let us know how it goes. 

Cheers

Anand Rao