Question

QuickLaunch on Wed, 25 Jul 2018 16:19:11


When clicking on a Excel file got this error:

"cannot open [path to file name]"

The library setting is set to "Open file in client application"

It happans on some computers but not on other computers.

Any clue why this happens? 

Thanks in advance on any tips!

Replies

MeRagZ on Wed, 25 Jul 2018 20:25:50


1. In the library settings->advanced settings->select “Open in the client application” for the Default open behavior.

2. Activate the “Open Documents in Client Applications by Default” in site collection features, and in the library settings->advanced settings-> select “use the server default” for the Default open behavior.

You could check the ULS log, the ULS log path is C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Logs and you could search excel or excel calculation services in the log file.

And you could reset IE to check if it can work. Go to internet options->advanced tab->reset.

And you also could do IIS reset to check if it can work.

If the issue still exists, you could create a new library and in the advanced settings, you could select “Open in the client application” for the Default open behavior to check if it can work.

Grace WR on Thu, 26 Jul 2018 07:28:44


Hi QuickLaunch,

Whether you have checked the points Raghava mentioned?

You can also go to IE->Tools->manage add-ons->check if the “SharePoint OpenDocuments Class” is enabled.

If the issue exists, what’s the version of Office? Try to repair the office application.

https://support.office.com/en-us/article/Repair-an-Office-application-7821d4b6-7c1d-4205-aa0e-a6b40c5bb88b?ui=en-US&rs=en-US&ad=US

Best regards,

Grace Wang

Grace WR on Thu, 02 Aug 2018 08:57:07


Hi QuickLaunch,

I’m checking how the things are going on about this issue. Whether the post helps you?

You can mark the post as answer if it helps.

Best regards,

Grace Wang